This forum now has forum rules - please read before posting!

bug: Movie clip audio when try to skip cutscene

Hi,

I have a cutscene. For this action list I set 'is skippable' to false.

In this action list I have a 'Engine: play movie clip'
with 'include audio' set to true and
'Player can skip' set to false

When I run that cutscene, the movie plays with audio. As soon as I press 'space' which is my 'skip cutsceens key', the video still plays, but the audio stops.

Did I miss any additional setting, or is this a bug?

regards
Mirko

Comments

  • In what version of AC and Unity?  The latest release allows you to use Unity's new VideoPlayer component - are you relying on that or the old Material method?
  • Hi,
    I am always using the latest version of AC and Unity 5.6

    As I wrote, I used 'Engine: play movie clip'

    this does use the new VideoPlayer, does it?

  • edited June 19
    It has many options within: the first being "Play clip", which is used to change how videos are played.

    Video Player is an option, but not the default.  Please post an image of the Action, together with the Video Player Inspector if that is what you are using.
  • btw, if I enable 'Black out when skipping' in the cutscene settings, the screen flashes black, when I press space, even though 'is skippable' is not enabled for the action list.
  • Try using a separate Sound to the Default Sound - create a new GameObject, add the Sound component and assign that in the Action instead.

    I still can't recreate the skipping issue, however.  As a test, reroute the ActionList so that an Engine: Wait of 5 seconds plays instead of the Engine: Play movie clip.  If you press the key mapped to "EndCutscene" while this wait occurs, does it still skip?
  • Hi,
    I will try the second 'default sound' tonight (it's my night-time-project -:)

    But I do not understand the Engine:Wait thing???

    It wont skip, nothing skips. Movie does not skip either. Movie plays, but sound of the movie stops when I press space. Movie still plays.
    The 'is skippable' option works fine. You can't skip the movie, a wait or anything else. Thats not the problem.

    If 'Black out when skipping' is turned on, but 'is skippable' is false. The action list is also not skippable, but the screen flashes black any time I press space.

    ("EndCutscene" is mapped to Spacebar in my case)

    I will report again when I tried the second sound object.

    If I find the time I will create a empty project which just plays the movie. Just to try if the problem is only in my existing project or in a new one also.
    If so, I will pack the project and send you a link as PM.

  • Nothing should skip if neither the ActionList not the movie Action are skippable.  It not skipping with the Engine: Wait Action is the correct behaviour.

    You say the "Is skippable" option is not the problem - but it sounds like it is, because the movie is skipping when you press the "EndCutscene" button.

    Once you've created a new project, please PM it to me with steps to reproduce so that I can see it for myself.
  • Sorry, maybe I did not describe it clear enough. English is not my native language ;-)
    So, no, movie is NOT skipping. ONLY the sound stops playing movie goes on.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Unity's Adventure Creator.