Forum rules - please read before posting.

System Cursor Not Locking

Hello everyone,

I am having an annoying issue. My system cursor does not want to lock the in-game view. First I thought it only happened in the Unity editor but when I build the game out I still get the same problem. I am using Unity's first-person player. I have Lock cursor in screen's center and I am using the Software renderer and Lock system cursor when locking AC cursor is checked. I am using Unity 2019.4 LTS and AC v 1.71.5. I really don't know how to solve this issue.


  • My guess is that Unity's first person player script is overriding control of the system cursor. You can confirm this by unsetting your current Player prefab / object, and assigning e.g. Tin Pot from the 3D Demo, who's also equipped to run in First Person.

    If so, it'll likely have to be a case of diving into Unity's first person player script and commenting out the offending code, something along the lines of:

    Cursor.lockState = CursorLockMode.None;
  • Hi Chris, no I have tried both ways. The problem is still there. So I don't think it is an AC problem. I will try and investigate it further. Thanks for your help though.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.