Forum rules - please read before posting.

Render buffer between scenes

When I change scenes, if I've done a specific thing beforehand, an image comes up of a previous point in the game between scenes. I've checked that it's just an image and not that the player is being teleported or cameras are actually changing. It;s like it's showing a screenshot of a previous moment. I have not got screenshots turned on. Ticking/unticking 'overlay current screen during switch' makes no difference. The 'screenshot' that it shows is the moment before the camera switches to a different one. I have tried remaking (and so also getting new constantIDs) for all the action lists, paths, cameras involved, making sure the whole process is identical to other comparable things.

I don't think it is a screenshot, I don't think its an image being put on the canvas (or you would see it in scene view). After much discussion, we think it might be some camera rendering buffer problem, but we can;t figure out why it only happens after a couple of things but not other very similar things.

See links for video and settings screenshot.


  • edited July 2020

    I'm switching scenes with Scene:Switch in an action list. The 'Loading' screen you see either side of the bug is a persistent object.

    I had just left the place that you can see in the scene view (and in the image that is flashed up) before going to the place that lets you change scene.

  • Fixed

    I'm going to leave this here in case anyone else hits the same problem because it took us ages to find a fix. Something is going on with the cameras. Sticking a loading screen up and then switching to a different camera before changing scenes stops this from happening.

  • I have a similar problem with my Map, which is a Unity UI menu, popping up just before the scene change - I had assumed it was akin to the problem other users were experiencing with previous lines of dialogue flashing on screen before a new line is displayed (which I get too, but I believe there is a fix for on the forums).

    Thanks for the hint - I'll get on that loading scene!

  • I'm not clear on where the "loading" message that appears is coming from. Is this an AC menu, or some separate script/asset?

    Try also the latest AC - even if it's in a duplicate project just to test if it solves this particular issue.

  • Chris, the loading screen is just a persistent object on it's own canvas, but it does the same if I use an AC menu for the loading screen.

  • Check the MainCamera's Inspector - it should list which camera it's attached to at runtime.

    Did you try the latest release?

  • No I'm sorry, I don't have time at the moment and this is a 'fixed' problem so I must concentrate on the rest. I am only a lowly cog in the machine. I will comment back here when we do the next AC update.

    The camera doesn't look as though it changes, I did watch for that before. But that doesn't mean it doesn't. It may but the inspector does not get updated during this 'blip'. Another thing I noticed was that I cannot catch the frozen image with windows print screen (tried multiple times and it always shows the next scene and made sure there wasn't a delay normally with print screen and there is not a long enough one to explain this) but xbox video capture does show it (link above). It's like the computer gets frozen for a second. It also happens on the switch build.

  • My version of this issue (where a menu that had been overlaid during gameplay appeared for a split second before the next scene loaded) has been resolved by updating to the newest AC.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.