Forum rules - please read before posting.

Navigating Sub-Menus UnPause the game for a few frames

Dear Chris and AC followers,
I've something very annoying and I can't figure out how to solve.
Basically my Pause Menu has some sub-menus (Options/Save/Load/Controls/Etc), but when I'm navigating between them the game is unpaused for a few frames (please note: ALL has the "pause gameplay when enabled") . Meaning my characters and sounds, play for an instance. This is annoying both visually and sound-wise (I hear a very short burst of ambience sound, while it should be deactivated when game is paused).
I've tried different options and I can't figure out what is causing this small (and yet annoying) glitch. So here I am asking for clues.
As I said, each of these sub-menus has the "pause gameplay when enabled", and an action list to run when Turn On. Also that action is set to "Pause Gameplay", and yet, when switching - for instance - between "Options" and "PauseMenu", the game is unpaused for an instant. There isn't anything weird on the action list when on (rather than locking the MainUI and things like that, menu related). Also, there's a simple action list on each button, which manually "crossfade" the menus, but again, I've tried with the AC crossfade or having no transitions, and yet the problem is still there.
Any clues? What could cause this?


  • edited October 2020

    In what AC version?

    Be sure to uncheck Unfreeze 'pause' menus? in your ActionLists - but the Demo game's pause menus, which use crossfading and transitions - doesn't have this behaviour, at least on my end. What if you switch your Menu Manager over to Default_MenuManager?

  • Oh, it was the "Unfreeze 'pause' menus?" thing I guess... Silly me! Still making rookie mistakes after almost two years of AC!

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.