Forum rules - please read before posting.

Subtitle Toggle Not Always Working

There seems to be an issue where the Subtitles Toggle option only seems to work if the Actionlist the subtitles are playing from are set to 'Pause Game'. When they're set to 'Run In Background' the subtitles stay on, rather than turning off.

Is there a way around this?

Comments

  • edited May 5

    What's your AC version, does the subtitle have associated audio, and is the Subtitles menu that displays background subs set to ignore the option?

  • It's 1.73.6. There is audio linked to all subtitles, yes. Ignore subtitles option is unchecked.

  • I'll attempt a recreation.

  • I can’t recreate such behaviour. Are you using separate menu for background speech? Let's see the Menu's properties, and the Action/ActionList that calls it.

  • Sorry to bring this back up, but the problem seems to actually be regarding actionlists that are running from within ANOTHER actionlist i.e. I have an actionlist that then calls another actionlist with the subtitles.

    They will play regardless of whether subtitles are set to play or not in the settings menu or if the toggle is set to 'no subtitles'.

    The subtitles won't show (as they should) when they're played direct from the original, first actionlist.

  • What are the properties of the ActionLists involved, and how does one call the other?

    Enable the AC Status box at the bottom of the Settings Manager. What is the "Game state" set to at the time this occurs?

    Again, please share screenshots of the related areas, as well as the menu's properties. I need to know the exact situation in order to recreate this issue.

  • Thanks Chris.

    Here's the OnStart cutscene, which starts the subtitle actionlist. I've tried it set to 'run in background' and 'pause gameplay' but it still shows the subtitles.

    Here's the called subtitles actionlist's properties:

    The AC status is set to normal:

    The subtitles menu properties:

    Here's the 'subtitle' file's actionlist layout:

    Here's the 'settings' menu with 'show subtitles' unchecked.

  • Is the audio coming from the video, or does each speech line has associated audio?

    If a speech line has no audio, the default behaviour is to show it regardless of the Subtitles option. This can be prevented by checking Force subtitles to display when no speech audio is found? in the Speech Manager.

  • That was it, Chris. The "Force subtitles" option. Blimey, can't believe I didn't work that out :( Thanks for your time, my friend!

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.