Forum rules - please read before posting.

Player movement issue after upgrading unity editor from v2020.3.16f1 to v2020.3.23f1

edited December 2021 in Technical Q&A

Hi Chris,

I'll try to be brief, after upgrading the unity editor from v2020.3.16f1 to v2020.3.23f1, my point and click player character won't move in my game scene. I'm running AC v1.74.4 in both my projects. Things I've tried:

  1. Compared player prefab settings to make sure they match from working project to new project,
  2. Updated the project settings input manager to insure it matches my 2020.3.16f1 project.
  3. Tested my player character in AC's 3D demo scene, my player can walk in AC's 3D demo. but not my scene.
  4. Dropped TinPot into my scene, though, he won't walk either,
  5. Rebaked the navmesh
  6. Created a new player character from scratch, he won't walk in my scene but does walk in AC's 3D demo scene.
  7. Double checked both animator and animator controller, all matches prior
  8. Also, tried running my scene using AC's 3D demo game managers.
  9. In my scene, changed movement method from point and click to direct, that works for some reason

That's it, any ideas?

Thanks, Tom


  • We'll need to see if this is related to point and click input, or pathfinding as a whole.

    Place down a Marker at the walkable position in the scene, and use a Character: Move to point Action to have the Player move there, with Wait until finish? checked. Do they move when this ActionList is run?

    If so, check that your floor is on the NavMesh layer and that there are no colliders in between the camera and the floor that may block point-and-click raycasts.

    Is the Console reporting any related messages?

  • Chris,

    I went straight away and checked the layering, my terrain was switched from the navmesh layer to backgroundimage layer, switched it back and my player walks again! Thank you. In addition to upgrading the unity editor to v2020.3.23f1 for this project I also recently updated AC to 1.74.4 from 1.74.3 for both projects, though the v2020.3.16f1 project has the terrain correctly set to navmesh so I presume the new unity editor caused the issue.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.