Forum rules - please read before posting.

Version 1.42 - improved workflow, new conversations and custom saving



  • edited February 2015

  • edited February 2015
    Same issue here: After downloading and installing Version 1.42 from the Asset Store, the version number in the Game Editor shows still "Adventure Creator - Versio 1.41b", but in the Store it says "1.42". BUT when you quit and start Unity again, it says "1.41b" in the Asset Store again. I retested the "Fixed: Menus of position Aligned and size Automatic having incorrect positions if their size changes mid-game" bugfix and it seems to be fixed - So it's definitely Version 1.42. I assume it's just a minor issue with wrong version details entered somewhere.

    The bad news: Some cutscenes of my current game seem to make problems after the update, I hope it's just easy fixes *fingers crossed* :)
  • I think I've solved the mystery..  The package you get (1.41a vs 1.42) is apparently based on what version of Unity you're using.  Apparently the new asset store tools allow for multiple versions online at once.

    To download 1.42, you must upgrade to Unity 4.6.2 or later.
  • Hmm, are you sure it's not just a display-issue? Why do i have the Menu bugfix in my version then? I'm using Unity 4.6.1f1. 

    Anyway, apparently the very first cutscene of my game has been destroyed by the update. It was a very long cutscene, and now there's only the first action in there :( The other cutscenes seem to work.
  • edited February 2015
    Of course you were right - I installed Unity 4.6.2 and then re-downloaded and installed the AC 1.4.2 again. I didn't have the "Show icon ins hierarchy window" option before, so it definitely wasn't 1.4.2 (strange the menu bugfix was in there though). 

    But something else occurred: When "Face after Moving" is enabled in an hotspot's "Examine Interaction" field, the waiting cursor appears and the game stops forever. Is this a bug or did i do anything wrong? 

    Edit: I tried to add "Character - Face Direction/FaceObject" Actions to the Interactions and discovered something else: When "Wait until finish" is selected, it also stops, BUT when "Is instant" is selected, it works. I changed this now for all my interactions and everything is fine again :)
  • edited February 2015
    I just found another thing :( I have music which is played across scenes. Every time I change the scenes, the music stutters a bit at the start of the next scene.
    edit: sorry for the 1.4.2 above, of course I meant 1.42. Everything is so confusing today :)
  • Hey Chris. These are some fantastic additions and many thanks for adding up several features which i was waiting for. The parallel actionlist (i was waiting for this the moment ActionList Editor was inlcuded to the AC) as well as global saving features are PERFECT! I cant wait to continue further with these features.

  • And the video is RAD! Really underlines the features with perfect ingame videos.
  • I'm on Unity 4.6.1f1 and AC 1.41a and it updated just fine.  Great update, Chris.  I retweeted on both of my twitter accounts!  :D

  • edited February 2015
    Awesome work, Chris! :) Thanks so much.
    Already RT. Will let you know how update goes. 
  • Updated to 6.4.2 and now I'm all good! Thanks Chris and community.

    Also, confirming that the cross-scene save-loading bug has been fixed! Super awesome.

    Happy AC'ing, everybody. :)
  • After update I still get a that error :

    MissingReferenceException: The object of type 'RuntimeActionList' has been destroyed but you are still trying to access it.
    Your script should either check if it is null or you should not destroy the object.

    UnityEngine.MonoBehaviour.StartCoroutine (System.String methodName) (at C:/buildslave/unity/build/artifacts/EditorGenerated/UnityEngineMonoBehaviour.cs:77)
    AC.ActionList.CheckEndCutscene () (at Assets/AdventureCreator/Scripts/ActionList/ActionList.cs:346)
    AC.ActionList.ProcessActionEnd (AC.ActionEnd actionEnd, Int32 i) (at Assets/AdventureCreator/Scripts/ActionList/ActionList.cs:304)
    AC.ActionList.EndAction (AC.Action action) (at Assets/AdventureCreator/Scripts/ActionList/ActionList.cs:262)
    AC.ActionList+<RunAction>c__Iterator1.MoveNext () (at Assets/AdventureCreator/Scripts/ActionList/ActionList.cs:241)
    UnityEngine.MonoBehaviour:StartCoroutine(String, Object)
    AC.ActionList:ProcessAction(Int32) (at Assets/AdventureCreator/Scripts/ActionList/ActionList.cs:171)
    AC.ActionList:ProcessActionEnd(ActionEnd, Int32) (at Assets/AdventureCreator/Scripts/ActionList/ActionList.cs:308)
    AC.ActionList:EndAction(Action) (at Assets/AdventureCreator/Scripts/ActionList/ActionList.cs:262)
    AC.<RunAction>c__Iterator1:MoveNext() (at Assets/AdventureCreator/Scripts/ActionList/ActionList.cs:241)

    Anybody know what that mean  ?

  • Unity 5 beta 22, updated just fine (well, I got a null reference the first time opening the new action editor, but now works awesomely).

    Sweet update, best asset I bought, just awesome.
  • edited February 2015

    I have updated to the latest AC. Now when I am in Conversation Editor, and I click on Create Interaction I get the following error:

    NullReferenceException: Object reference not set to an instance of an object
    ConversationEditorWindow.NodeWindow (Int32 ID) (at Assets/AdventureCreator/Scripts/Logic/Editor/ConversationEditorWindow.cs:265)
    UnityEngine.GUI.CallWindowDelegate (UnityEngine.WindowFunction func, Int32 id, UnityEngine.GUISkin _skin, Int32 forceRect, Single width, Single height, UnityEngine.GUIStyle style) (at C:/buildslave/unity/build/artifacts/EditorGenerated/GUI.cs:1443)
    ConversationEditorWindow:OptionsGUI() (at Assets/AdventureCreator/Scripts/Logic/Editor/ConversationEditorWindow.cs:196)
    ConversationEditorWindow:OnGUI() (at Assets/AdventureCreator/Scripts/Logic/Editor/ConversationEditorWindow.cs:63)

    Any help in the right direction will be greatly appreciated.
  • I was able to move past the problem I reported.
    In Scripts/Logic/Editor/ConversationEditorWindow.cs at line 264, I just added the load again for the ACNodeSkin.guiskin like this:

    nodeSkin = (GUISkin) AssetDatabase.LoadAssetAtPath ("Assets/AdventureCreator/Graphics/Skins/ACNodeSkin.guiskin", typeof (GUISkin));
    if (GUILayout.Button ("", nodeSkin.customStyles[13]))

    This seem to solve the problem. Very strange that it didn't work from the class declaration level.

  • Also it seems "strange" that for conversations, for each option interaction I have to create, in case I don't require one, now i have to DISABLE that option's action or I get an error:

    NullReferenceException: Object reference not set to an instance of an object
    AC.ActionList.Reset () (at Assets/AdventureCreator/Scripts/ActionList/ActionList.cs:385)
    AC.ActionList.Interact () (at Assets/AdventureCreator/Scripts/ActionList/ActionList.cs:97)
    AC.Conversation.RunOption (AC.ButtonDialog _option) (at Assets/AdventureCreator/Scripts/Logic/Conversation.cs:125)
    AC.Conversation+<RunOptionCo>c__IteratorD.MoveNext () (at Assets/AdventureCreator/Scripts/Logic/Conversation.cs:164)
  • With new features come new bugs, but with swift reporting I should get a swift update out, too.

    @JDuaneJ: One of the reasons new tutorials are text-based, rather than video, is so that I can update them when needed.  I try to keep on top of them, but please point out those that I’ve missed.

    @dxmachina: I’m planning a new 2.5D tutorial, yes.

    GrzegorzPEdrycz: Please make a new thread / PM me the exact steps needed to re-create this.  This bug will likely be a result of a unique way of running an ActionList asset, so I’ll need full details + screenshots.

    @Nick: Please elaborate on that last one - are you using the new “Conversation override” feature?
  • edited February 2015
    I have uploaded a small clip here showing what I am doing:

    Let me know if you require more information.
  • @Nick: Thanks.  Actually, the disabled step is irrelevant - the ActionList itself is only built when it's viewed in the Inspector/Editor.  When you go to check the problem, it's created, which means it'll work whether you disable it or not.  I'll get a fix out for 1.42a regardless, however.
  • = Version 1.42a =
    • Added: Option to invert panning in ActionList Editor window (now set to pre-1.42 behaviour by default)
    • Fixed: Errors if an ActionList is triggered before it has been viewed in the Inspector or ActionList Editor window
    • Fixed: ActionLists with a start delay no longer running correctly
    • Fixed: Speech Manager not detecting ActionLists referenced by “Engine: Run in parallel” Action
    • Fixed: Sounds that survive scene changes fading in after changing scene
    • Fixed: Music set to play while the game is paused stopping when it’s volume is changed
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.