Forum rules - please read before posting.

Very BIG issue with inventory after save game

edited October 2015 in Technical Q&A
Hi Chris,
I recently noticed, with AC ver. 1.48a, that if I save the game after grab an object, stop the game, restart the game and load the saved game, in the inventory I don't have that object and in the scene the object there isn't...!!! 
In the inventory I only have object with "carry on start" checked... hope this is a bug, because I don't know how to fix it! 

Comments

  • Found this on console:

    The referenced script on this Behaviour is missing!
    UnityEngine.Resources:LoadAll(String, Type)
    AC.AssetLoader:RetrieveAsset(AudioClip, String) (at Assets/AdventureCreator/Scripts/Static/AssetLoader.cs:80)
    AC.Player:LoadPlayerData(PlayerData) (at Assets/AdventureCreator/Scripts/Character/Player.cs:666)
    AC.SaveSystem:ReturnPlayerData(PlayerData, Player) (at Assets/AdventureCreator/Scripts/Save system/SaveSystem.cs:1619)
    AC.SaveSystem:ReturnMainData() (at Assets/AdventureCreator/Scripts/Save system/SaveSystem.cs:1409)
    AC.SaveSystem:OnLevelWasLoaded() (at Assets/AdventureCreator/Scripts/Save system/SaveSystem.cs:721)
    AC.SaveSystem:LoadSaveGame(Int32) (at Assets/AdventureCreator/Scripts/Save system/SaveSystem.cs:625)
    AC.SaveSystem:LoadGame(Int32, Int32, Boolean) (at Assets/AdventureCreator/Scripts/Save system/SaveSystem.cs:500)
    AC.MenuSavesList:ProcessClick(Menu, Int32, MouseState) (at Assets/AdventureCreator/Scripts/Menu/Menu classes/MenuSavesList.cs:549)
    AC.PlayerMenus:CheckClick(Menu, MenuElement, Int32, MouseState) (at Assets/AdventureCreator/Scripts/Controls/PlayerMenus.cs:1465)
    AC.PlayerMenus:CheckClicks(Menu) (at Assets/AdventureCreator/Scripts/Controls/PlayerMenus.cs:1216)
    AC.PlayerMenus:UpdateAllMenus() (at Assets/AdventureCreator/Scripts/Controls/PlayerMenus.cs:1379)
    AC.StateHandler:Update() (at Assets/AdventureCreator/Scripts/Game engine/StateHandler.cs:234)
  • Update: I tried with a previous backupped version with AC 1.46e and items I get were saved correctly in the inventory after load... 
    I noticed the previous advice on the console there was also there, but I have the item in inventory.
  • Update to v1.48b - it should fix that very issue.
  • Very thanks man! That solved the inventory "item disappeared" issue.

    Just a clarification: in the release notes you wrote for IOS, but my target platform is set to Windows.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!