Forum rules - please read before posting.

managers not working from 1.48b to 1.51?

so I'm trying to upgrade but something is very weird.

I've imported the entire new version (except project settings) and then run my manager package to put my managers in.

They're simply not working right at all.If I put demo managers in everything is working, UI, player, etc... if I put mine in nothing is working, no UI, no player movement, the camera doesn't switch to first person... it's like they're not even compatible now.

Anyone know what to do? The only other thing I can think of is load backup yet again and delete the manager package and make a new one, and *maybe* that would help? This is in Unity 5.3.1f1 btw.


  • Anything appearing in the Console window?

    Try assigning the Demo managers save for the Settings Manager, which you should leave as your own - does the base movement work then?
  • Nothing in the console.

    I tried going through the different ones though and it seems it's only one that's completely destroying things is the variables manager. Everything else I can load if that isn't loaded. Nothing really weird going on in my variables except some globals are linked to playmaker, maybe that's causing something?
  • There haven't been any changes to that feature in between v1.48 and 1.51, but the only way to know would be to unlink the variables and try again.  You can re-link them afterwards (do this all in a backup project if you prefer).
  • edited March 2016
    Well results...

    yes the variables are working after disabling their connection to PM.seems that was a problem. O_o

    Very weird. I'll have to keep looking at what's going on but I'm doing various stuff inbetween right now slowing me down
  • what does 

    disabling their connection to PM mean? what 

    I think this is one of the things i had when trying update, managers went haywire :/

  • edited March 2016
    Well I had used some Adventure Creator variables that under their properties option in the variables manager used Link to: Playmaker Global Variable.(Which is another tool I use so if you don't use it there's no way this is your issue.)

    I had to reset that to none (and then reenabled them for PM later and they worked) Lucky I didn't have a huge amount of them to reset, but that seemed to solve any problems somehow.
  • oh, thanks for clearing that up.

    Im not using PM so this wont help me :/
  • @klarax: Please post your issue in a new thread with appropriate details.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.