Forum rules - please read before posting.

Skip all animations in an ActionList


When i skip an Actionlist with an Animation, the last Animation after skipping is still active. It literally repeats the movement again which is not good! I looked in the scrips and I tried to find the solution but I can't work it out! Someone else also having this problem and knows a solution? If so: pleaaaase.. and thanks!


  • edited June 2016
    Problem was in the ActionCharAnim.cs (obviously)

    Commenting out the lines in the override function Skip solved it. However, I am not sure if this is 
    the right way @ChrisIceBox.

    override public void Skip ()
    // if (animChar)
    // {
    // if (animChar.GetAnimEngine () != null)
    // {
    // animChar.GetAnimEngine ().ActionCharAnimSkip (this);
    // }
    // }


    (Using AC1.51B and Unity 5.3.1f)
  • Have you read Section 5.5 regarding skipping Animation Actions?
  • edited June 2016
    Oh sorry I didn't know, I looked over it! But yes, I did read it now. But in my case I use my animations (pick up, hand or arm movement) on the second layer, and I like to use them as trigger. If I say Character : Animate, Method: Play Custom and Clip: Idle after my hand animations on the second layer (layer 1), it can't find my animation Clip. Probably because the layer is only active for the arms and not for the rest of the body. Also, I need to change the Parameter value to crossfade, but maybe this is not possible with triggers. Because I can't put a trigger off in AC (because triggers don't work that way in Unity), it's a one call job. So that is already a problem. Maybe it is better to use bools instead? I will try something and report it back.
  • If you want to avoid an Action completely when skipping, you can also use the ActionList: Check running Action to re-route your list.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.