Forum rules - please read before posting.

Possible Bug - Default Language is #1 instead of #0

The "original language" (0) in my game is English yet the game is choosing the second language / first translation (1) as the default language instead of English. "Prevent original language from being used" is unchecked. It seems to work fine in engine and on the pc I build to (save files are cleared before testing).

I have a menu that comes up in the beginning of the game to choose the language, using a Cycle. That's the only place in the game that changes the language. Whether I have this menu on or off the game is still choosing language 1 as the default instead of 0. Can confirm this is happening on both PCs and Macs. 

Using Win 7 PC, Unity 5.4.1f1 (64-bit), AC 1.54b


  • As Options data is save game-independent, its stored in PlayerPrefs rather the save files.  Deleting save files won't clear it, so you'll have to search the Unity docs about deleting PlayerPrefs data instead.

    Once cleared on your system, try clicking Reset options data in your Settings Manager and setting the Language to 0.  The fields there are the "default" values, which are used by AC when creating options data on a system for the first time.
  • Ah, perfect! People kept telling me the game would only play in Russian and I couldn't figure it out for the life of me why. This works, thank you! 
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.