Forum rules - please read before posting.
Tech questions during the weekend? Drop in on the community Discord channel!

NPC subtitles cutting off Player subtitles

AC 1.64.5
Unity 2018.2.8f1

I have an NPC with a dialogue loop cutscene 'Math Loop' playing in the background of my scene with the 'Math Loop' cutscene set to run in background. The dialogue with in the cutscene for the NPC is random variable so therefore cannot be set to Play In Background for each dialogue as then they just play over each other. Whenever the NPC talks in removes the Player subtitle. And even if the Dialogue options are set to Play In Background it cuts off the Player subtitle. Please look at Speech menu and let me know what I can do to stop this:

Comments

  • Have a look in your Menu's for what displays dialogue. Ideally you would create a separate menu for either this NPC or background lines, and set the 'For speakers of type' and "For speech of type' fields suitably.

    Also! For your action list, if they all have the same wait time, you can just have one and have all the dialogue skip to that one. That way if you want to adjust the wait time you don't have to change them all individually :)
  • Hi, I tried this and it didn't change a thing. See my new Subtitles. Same thing happened, even with Play in background selected, it removes the Players subtitles when NPC Subtitles are played:

    https://www.dropbox.com/s/5040e8qvj1bglam/Screenshot%202018-09-19%2010.54.13.png?dl=0

    https://www.dropbox.com/s/b2tccyz6nc2oak0/Screenshot%202018-09-19%2010.54.09.png?dl=0
  • Also, the same character will sometimes be in a dialogue loop in the background, and then talking to the player in the same scene
  • Recreated the "cutting off" issue - will look further into it.

    Regarding the loop occuring at the same time as talking to the Player - that's up to your own game logic to prevent.  Pause the background loop with ActionList: Pause or resume if you don't want it to run while the NPC is talking to the Player.
  • Check Duplicate for each line? on both Menus to stop them cutting off each other.

    Neither of your menus are configured to display blocking speech spoken by your NPC - "Subtitles NPC" is for background only.  Instead, try leaving out the "Specific characters" options, and just have the menus separate blocking vs background speech.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!