Forum rules - please read before posting.
Tech questions during the weekend? Drop in on the community Discord channel!

Could not initialise NavMesh - was one set as the Default in the Settings Manager?

I keep getting this message in my console?

Could not initialise NavMesh - was one set as the Default in the Settings Manager?

I have a Nav Mesh set for the scene, but I can't seem to see where I would place one in the Settings manager?

Comments

  • edited January 2019

    The Scene Manager is where NavMeshes are set. What's your AC version?

    What's your Pathfinding method set to in the Scene Manager? It shouldn't show if you're using Polygon Collider.

  • Hi, am using ac version 1. 66.2

    It is set to Polygon Collider
  • Post the error message in full.

  • Could not initialise NavMesh - was one set as the Default in the Settings Manager?

    -> AC debug logger
    UnityEngine.Debug:LogWarning(Object, Object)
    AC.ACDebug:LogWarning(Object, Object) (at Assets/AdventureCreator/Scripts/Static/ACDebug.cs:25)
    AC.NavigationEngine_PolygonCollider:OnReset(NavigationMesh) (at Assets/AdventureCreator/Scripts/Navigation/NavigationEngine_PolygonCollider.cs:88)
    AC.NavigationManager:ResetEngine() (at Assets/AdventureCreator/Scripts/Managers/NavigationManager.cs:66)
    AC.NavigationManager:OnAwake() (at Assets/AdventureCreator/Scripts/Managers/NavigationManager.cs:38)
    AC.SceneSettings:OnAwake() (at Assets/AdventureCreator/Scripts/Game engine/SceneSettings.cs:94)
    AC.MultiSceneChecker:Awake() (at Assets/AdventureCreator/Scripts/Game engine/MultiSceneChecker.cs:49)

    1. Any change if you unset OnStart?
    2. Any difference between starting the game from this scene vs switching to it from another?
    3. Is navigation actually possible despite the message?
  • 1.no change

    1. It’s when any scene switches to another. Starting in scene it’s fine

    3.Yes

  • How many scenes can you enter this from? If you create a fresh scene and switch to the problematic one, does the error show?

  • it seems that this actually happens when changing to a new scene from every scene

  • edited February 2019

    As in, from any scene to any scene? Please answer my question about this occuring from a fresh scene.

    In a problematic scene, find your Scene Settings component on the GameEngine object - is your NavMesh field correctly assigned?

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!