Forum rules - please read before posting.

Unlock cursor after clicking hotspot

Dear friends,

My question would be that. I use Adventure Creator, I started to work with it in these days. As you can see on the picture my interaction method is: Choose Hotspot then Interaction. Besides I use the lock cursor settings, and after I clicked on Hotspot I would like to move my mouse free, so I should unlock the cursor (based on Chris's perfect manual), but I couldn't figure out, where can I set it? Please help me!:)

Here are my settings:

«1

Comments

  • Have you tried changing something either in the Hotspot menu or Interaction menu panels? Like, for example, set that the Interactions appear on cursor and then freeze?

  • Welcome to the community, @bali02.

    When do you want the cursor to unlock? While the Interaction menu is showing?

    If your Interaction menu has Pause game when enabled? checked in its properties, then the cursor should unlock automatically.

    Otherwise, you can use the Player: Constrain Action to unlock the cursor at any time. In the Interaction menu's properties, you can assign ActionLists that run both when it turns on and off. You can use this Action to unlock the cursor when the menu turns on, and lock it when the menu turns off.

  • When I put Player with Character Wizzard to the scene it doesn't work. It's locked. And my controls are strange too, besides that I checked my Input settings.

    Without Player it works, if I go with camera in the air.:)

    Do you have any suggestions? Thank you:)

  • You'll need to me more specific. In what way are the controls "strange"?

    Check the Console window for messages - does anything relevant appear at runtime?

    The 3D Demo game's Player, Tin Pot, is also configured to work in First Person. As a test, disable your own Player and drop Tin Pot into your scene file, then run the game. He can be found in /Assets/AdventureCreator/Demo/Resources/Tin Pot.

    Does placing him in the scene cause things to then run correctly? If so, then there is a problem with your own Player - in which case, post screenshots of his Inspector. If not, there may be an issue with your settings - in which case, post screenshots of your Settings Manager and Input settings.

  • Thank you for your fast reply!:)

    I put your Tin Pot character, and my experiences that:

    • A,S,D,W all of these buttons mean only vertical positive, character moves to vertical positive only.
    • I can't see hotspots in my scene, when I arrive to (for example) a door, So I can't test interactions neither.

    I can send my inputs settings too, if you need it. And I can send screenshots yet, just please write me what do you need?:)))

    Really thank you!

  • edited February 16

    Yes, please post screenshots of everything on e.g. imgur.com, and link to them here. Player, Settings Manager, Input settings (with the Horizontal and Vertical axes settings expanded).

    What do you mean by "can't see hotspots"? You're talking about the "Hotspot" label that should appear? That should be part of your default interface, if you opted to use it in the New Game Wizard. Let's see a screenshot of your Menu Manager, and the Hotspot menu inside it.

    If you temporarily switch your Menu Manager's Asset file to Demo_MenuManager, which uses the default interface, does it then show during gameplay? You can switch back to your own Menu Manager asset file in the same way afterwards.

  • Thank you very much! Now the hotspots problem works perfectly.

    One problem exists yet: when I control the player (Tin Pot), when I push A,S,D,W buttons, the player moves only vertical positive. Any idea Master?:)

  • What do you mean exactly by "vertical positive"? Is he moving upwards, or forwards?

    Is it always forward from the direction the Player is facing, or does he move along the same axis even if you manually rotate the Player in his Inspector?

    Again, please share screenshots of your Player, Settings Manager, and Input settings. This isn't an issue reported elsewhere, so we'll need to see more information about your specific setup.

  • Okay, I'll make screenshots.
    The Player is Tin Pot, because my main character isn't ready yet.

    When I push A,S,D buttons without moving mouse, the player moves forward only. When I use mouse and push W/A/S/D the player moves and rotate bye cursor.

    So the problem is A/S/D buttons settings. Because I would like that:
    A - go left (without camera rotate)
    S - go back (without camera rotate)
    D - go right (without camera rotate)

  • When I use mouse and push W/A/S/D the player moves and rotate bye cursor.

    Moves in which direction? Again, always forward along the same axis, or in front of the direction the player is facing?

    Make sure that your Settings Manager's Turning type field is set to Relative To Camera. The default behaviour of ASD should be to move the player without turning. Let's see those screenshots.

  • The problem is that you can't see on screenshots my problem:)) because hotspot problem is solved already, and my problem is direction, when I push A the player moves forward, I would like that if player would go left when I push A button on keyboards, and would go right when I push D button, and go back when I push S button.:)

    But now if I push all of these buttons the player moves forward only.:/

    I would make screenshot, but you wouldn't see the difference between 2 pictures:)

  • edited February 21

    The behaviour you're looking for is the behaviour it should be.

    I'm not asking for screenshots of the issue in the Game window - I'm asking for shots of your Input Manager, Settings Manager and Player. Again, please provide - as well as let me know the result of assigning the Demo_SettingsManager asset file.

  • Ohh Okay, I understand, so with the Demo....... asset file it should works...I'll try it today later and i'll write:))) Thanks man:)

  • edited February 23

    Here is the pictures.

    My other problem is that, my player doesn't detect moveable objects (I created moveable gameobjects by AC and put the real object "under" this gameobject), when player is close to the for example pickup object, there isn't icon and I can't drag it.

  • Please follow my instructions carefully - it's something very specific that I need to see.

    Input settings (with the Horizontal and Vertical axes settings expanded).

    You have two sets of both of these axes listed - please share screenshots of all four axes expanded.

    My other problem is that, my player doesn't detect moveable objects

    Try this, too, with the Tin Pot demo player - does it work with him? What are your AC and Unity version numbers?

    when player is close to the for example pickup object, there isn't icon and I can't drag it.

    You have Hotspot icons set to Never. For an icon to appear when hovering over it, you'll need to allow this, and attach a Hotspot component with Single 'Use' interaction and an empty Use interaction defined (see the First person tutorial).

  • Here is the screenshot:

    I use only Tin Pot player until the solution, so no, Tin pot can't pickup the moveable object and can't see it.

    My Unity version: 2018.3.0f2
    Ac version: 1.66.7

  • As I said, you also have another pair of Horizontal/Vertical inputs - I need to see both.

    I think it's time to see your project itself. Create a test scene that demonstrates both issues clearly, zip up the whole project and send me a private link to it via PM.

  • So, I made a new project, and I use there my game managers, and everything works fine in the new project file with controls, so I don't understand what could be the problem in my original game project.:/

  • After I closed this new project and open it again, there is controls problem again. I zip-ed this project file. I sent you an email with the download link. Really thank you Chris!

  • You have a third-party script attached to your camera that causes it to move. Remove it.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.