Forum rules - please read before posting.

HELP, Adventure creator dissapeared!

I might have lost all my progress, and i don't know what i did wrong. i was looking for unitys visual effects assets and firstly installed/imported the "Standard assets package", when imported i figured out it was dated and found to "Post processing package" and installed/imported that. Then i shut down unity to reopen my gamefile and adventurecreator was just GONE from my project. i tried reimporting the asset, but it didn't work. please help me, i would be so sad if i lost everything i have worked on.

Sincerely Philippa

Comments

  • Make sure the AC managers are referenced!

  • I got it back! Something in the "Post processing package" clashed with adventure creator. is there any way i can get them to work with eachother? I'm interested in using the post processing package's color grading tool (to make my scene black and white in some instances) and i've never coded before so it seemed ideal for me.

  • edited August 2019

    well i got back the AC windows and assets, but all my actionlists, inputs and everything i've done in the managers are gone :( Any way to get that back, or do i have to assign everything again?

    [edit]
    Found solution: assigned the old manager files

  • i tried recreating the problem, and this warning shows up:

    Assets\PostProcessing\Editor\PropertyDrawers\MinDrawer.cs(6,34): error CS0104: 'MinAttribute' is an ambiguous reference between 'UnityEngine.PostProcessing.MinAttribute' and 'UnityEngine.MinAttribute'

  • Make sure to backup before importing other assets. Though, you should make backups at regular intervals anyway, just to be safe.

    Also, Post Processing Stack is imported via the Package Manager these days, not the asset store. I say this because I am using it with Adventure Creator without any problems, so maybe you imported the wrong version.

  • The console warning is a compilation error, coming from the PostProcessing asset. If Unity can't compile, then restarting it will prevent all Editor assets from loading - including AC.

    It sounds like this asset is outdated - as @Deckard_89 suggests, you should look to import it from Unity's Package Manager, instead of from the Asset Store.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!