Forum rules - please read before posting.

Trouble with AC NavMesh and Hotspot

Hey guys,
I'm coding a 2D adventure game for university and I'm running into a few problems here. It could very well be, that I'm doing something terribly wrong, for which I want to excuse myself beforehand, if that's the case. If not, I hope there's a fix to this bug >-<

I have a scene in which the player has to push around crates which block his way (still a prototype so very generic graphics). Nothing special up to now. The more crates the player pushes, the more of the path he is able to walk on. Thus I created several NavMeshes which I change with an ActionList as soon as the player pushes a crate. 

The problem I ran into now is, that one hotspot ceases to work as soon as I add more vertices to the polygon collider. It is only this one hotspot...
Here are a few screenshots to show you what I mean:

Before I added additional vertices to the collider (hotspot works):image

And after I added vertices to the polygon collider (here the hotspot doesn't work anymore):


I hope somebody has an idea how to fix this or can tell me what I'm doing wrong. Because I seriously have no idea :/

I really appreciate any answers whatsoever, as fast as you can >.<
Thanks a lot! 


  • Thank you @Valdur, that was my thinking as well - the issue sounds similar.

    @Philvzg: Which version of Unity are you working with, and does this issue occur in builds?
  • First of all, thanks for all your answers! 
    The issue sounds indeed similar to what he mentioned there, but in the post I can't seem to find a fix for the problem...setting the "z" of the 4 NavMeshes to a value of 10 doesn't change anything though :/
    I'm using Unity version 5.3.5f1 Personal
    What do you mean with your last question Chris? :/
  • I'm asking if the Hotspot is un-clickable when you build the game, as opposed to just when testing in the Unity Editor.  That was a key point in Valdur's issue.
  • No, when I build the game it also does not work.
  • So yes, the issue does indeed occur in builds as well.
  • Is there anything I can do about it?
  • Create a duplicate scene and remove all other Hotspots and NavMeshes, so that the problem is obvious and occurs as soon as the scene is run.  Then create a .unitypackage file (not a zip) containing this new scene, and your game's full set of Managers (8+1 files in total).  Then PM this package file to me and I will take a look at it.
  • The thing is that the issue only occured after the third NavMesh was added. Before the hotspot worked fine :/
    So it could be that it has to do with the other hotspots and/or NavMeshes. Should I really delete the others, since it could make the problem less obvious?
  • I just tested what happens if I delete the NavMeshes and Hotspots. Removing the other hotspots has no effect on the functionality of the problematic hotspot, but deleting two of the 4 NavMeshes I have created so far makes the hotspot work again. But I need the NavMeshes, otherwise I can't dictate how the player behaves before and after he moves the boxes...
  • Don't delete anything that causes it to work again.  You should find that the inactive NavMeshes are placed on the Ignore Raycast layer, and that the active NavMesh is on the NavMesh layer (which you should create manually if it doesn't exist).

    If this is the case, keep whatever NavMeshes you need in it an send it to me in the way I described.
  • edited June 2016
    I sent you the project. There's another strange thing about this I have noticed.
    When I delete the hotspot in question and duplicate the hotspot of Box2 and put it on the exact same spot where the hotspot of Box1 was, he works just fine, when I insert the new hotspot into all the interaction values.
    But as soon as I edit one of the NavMeshes, add a new one oder edit a NavMesh, the hotspot of Box1 fails to work again. This process is repeatable in my project, so as soon as the hotspot fails to work correctly I can duplicate another hotspot and it works again. It's really strange.

    Oh - and when I close Unity and open the Scene up again it fails to work. Replacing the hotspot with a duplicate of Box2 fixes it again temporarily at that point.
  • Okay, next thing I noticed - at the top and bottom of the hotspot of Box1 are tiny fractions of the hotspot that still seem to work. Like literally 1-2 Millimeters in thickness.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.