Forum rules - please read before posting.

No experience, Complete Beginner, Navmesh Hole problem

Hello, I cannot for the life of me figure out why the Navmesh Tree Hole in the 2D Demo will not work.  I create it exactly as seen on the video, when i attempt to play the scene, the Tree Hole doesn't seem to exist, also when using the default sorting map, the tree still covers the Player regardless of layer it seems. Please help, this is really frustrating.

Comments

  • Note : Tree Hole is there, just doesn't affect the character. Same with the sorting map.
  • Welcome to the community, @jvdahmen.

    Without seeing screenshots of your scene, I can only give a list of things to check for.
    • Ensure that your Camera perspective in the Settings Manager is set to 2D, and Moving and turning is set to Unity 2D.
    • Make sure that your hole fits entirely within the main NavMesh, i.e. the two shapes do not intersect each other.
    • Register your hole in the NavMesh component - select the NavMesh, and set Number of holes to 1, then assign the first hole as your hole object.
    • Make sure that the NavMesh is assigned as the Default NavMesh in the Scene Manager.
    • For the tree, make sure that the Sorting Map area beneath it has a larger sorting order value than that on the tree sprite itself.
    • Make sure the player sprite has a Follow Sorting Map component, and that the default sorting order of the player sprite is zero.

    If you still have issues, please post some screenshots of your scene, and the relvenat object inspectors, and we can give more specific advice.

  • edited June 2017
    hallo im new with adventure creator i just wanted to let you know i had the same problem i just figured it out my self and i wanted to share it with you so :
    first go to the game editor then to scene then to scene settings then to default navmesh make the nave mesh that you created there drag it and put it on this little box save and now your treehole should be totally assigned he did it on the 11.39 on the tuto i just didnt pay attention i saw it when i figured it out and watched the video again
    this problem took me hours to figure it out so decided to share to help community as the others instead of beiing lazy and just take answer and run :)
  • edited January 2018
    Same problem here.  Followed directions to the letter (as far as I can tell).  Started up from the beginning and followed the tutorial through as directed.  

    Not sure if this is related, but when I was dragging the game assets into the hierarchy window, they didn't appear in the scene window like yours (Chris') did.  I've had to do a lot of messing around with reseting positions to 0 and changing my view.  I hadn't moved the scene around before starting the tutorial.  After restarting unity and the tutorial about 5 times I was still unable to have the assets appear in the scene window when dragged in.  Related to the hole in navmesh problem??  not sure.  

    Love the program and your tutorials, just trying to get it figured out!  Thanks in advance for your help!
    (Trying to post a screenshot.  can I browse to a pic on my computer somehow?  It's just asking for a url)

  • edited January 2018
    https://drive.google.com/file/d/1zj7AB8SRQSVBixHgmd2aXH1mxLfFxQLG/view?usp=sharing



    There's probably an easier way to get a pic on here, but doesn't seem to be working for me, so hopefully these links work.
  • Welcome to the community, @bvandiviere.

    I can't see the PolygonCollider of your "TreeHole" object - is it surrounding the base of the tree, and entirely within the boundary of the main NavMesh?

    The Inspector and Scene Manager look fine, so it could well be related to the position issue.  Could you elaborate on that?  If they don't appear in the scene window, where are they going?  Are their positions way off-screen somewhere?  That sounds like a Unity issue, as that part of the tutorial just uses Unity's interface.

    About sharing images - see the forum rules.  Images can't be uploaded directly onto the forum, but can be shared on image-sharing sites such as imgur.com and then linked to from here.
  • Thanks for the quick reply!

    I've included another link to pic for treehole.  I'll get an imgur account setup for future discussions.  

    The treehole is surrounding the base of the tree and entirely within boundary of navmesh.

    I deleted my projects and started fresh again.  This time I didn't have a problem with the origin position, but am still having the same treehole issue.  I think I must have set up the original unity project as a 3D project or something.  This time I did it as a 2D and everything came up on the same origin.

    So, for whatever reason, the treehole still will not join with the navmesh.  Let me know if I can get you anymore info that would be helpful.


    Thanks!!
  • Again, the screenshot looks OK to me - and I can't reproduce this issue in Unity 2017.3.  You're using AC v1.60.7?

    Be aware that the hole only joins the NavMesh at runtime - you should find that when selecting the NavMesh in the Scene window during gameplay, you can see the hole incorporated into it.

    If you enable "Gizmos" in the Game window at runtime, you should also be able to see both the hole and the player's path as a series of white dots connected by blue lines.  They definitely ignore the hole and go straight through it?

    As all looks fine, I'm not sure what else to suggest.  You're welcome to PM me a .unitypackage file of your "My 2D game" folder for me to take a look.  Including the "AdventureCreator" folder won't be nececssary.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!