Forum rules - please read before posting.
Tech questions during the weekend? Drop in on the community Discord channel!

2.5D Tutorial - Footsteps only sound after clicking hotspot

I'm doing the 2.5D tutorial, and have just gotten through the part assigning footsteps sounds to the girl.  

To get to this point, she was created, made into a prefab, FootstepsSFX was created and assigned to SFX Sound Child of the girl, girl deleted from heirarchy.

When I play the scene and walk around, there are no footsteps.  Once I click on a hotspot to move to the next scene, I hear the footsteps.  Once I get to the next scene, footsteps are gone again until I click the next hotspot.

Thanks in advance for your help!

image

Comments

  • Unity 2017.3.0f3
    AC v1.60.7
    MacOs High Sierra 10.13.2
  • Next scene or next background/camera?  The 2.5D tutorial only involves one scene.

    Try dropping in Tin Pot, the 3D Demo player into the scene and assign the same AudioClip - does the same thing happen?  What layer is the girl's root object placed on?

    The "Footstep Sounds" component is another way of playing footstep sounds - see the Manual's Section 3.8.
  • Make sure that the Player's Ground-check layer(s) field matches the layer that the floor is on.  If you're following the tutorial exactly, they'll be on the NavMesh layer.
  • Poor choice of words, sorry -- I meant next background/camera -- moving from the waterfront to the steps, or steps to plaza etc.

    I put Tin Pot in, and assigned the footsteps file and sound child as laid out in the tutorial.  The same thing happens.  

    What I've noticed is that the footsteps don't start as soon as I click on the hotspot and he starts walking, but only when the player enters the hotspot zone.  For example, when I click on "exit to steps," tinpot/girl starts walking toward steps with no sound.  As soon as they enter the zone with the hotspot I then hear the footsteps.

    Both players are on the Ignore Raycast layer.  I'll have a look at the other method of assigning footsteps for now.  
  • Make sure that the Player's Ground-check layer(s) field matches the layer that the floor is on.  If you're following the tutorial exactly, they'll be on the NavMesh layer.

    This worked, thanks!  I did go back and watch the tutorial from character creation through the footsteps creation and didn't see it mention changing the Ground-check layer to NavMesh.  Does it come later in the tutorial or is it during the creation of the Navmesh?  At any rate, the footsteps are there now, thanks!
  • Neither - it's a new option introduced since the tutorial was filmed.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.