Forum rules - please read before posting.

Auto-select Pause menu element while conversation UI is displayed

Might be an edge case, but when pressing Pause while a Conversation menu is visible with dialogue choices, the first element of the pause menu is not selected even if Auto-select is enabled. The pause menu works great in all other cases and the first button is selected automatically for direct controller input.

If I disable Auto-select on the Conversation Menu, the Pause menu starts working again - maybe there's an issue with two menus having auto-select enabled? I tried creating an Actionlist that runs when the Pause menu is turned on which selects the first element, but that didn't work either. It seems that the conversation menu is blocking this functionality on the pause menu.

Both menus are Unity UI, direct controlled, AC 1.70.4, Unity 2018.4.


  • Is there any change with the current release, or if you move the Pause menu down the Menu Manager stack so that it's beneath the Conversation menu?

  • Ah, chef's kiss - Moving the Conversation menu to the top solved the issue!

  • edited May 2020

    In the latest version (1.71.2) I'm having trouble with a menu not enabling auto-select.

    From the Pause menu you can click the Options button (with a crossfade click type), and when this menu appears the first element is not selected. If I click with a mouse, the menu is activated and works again, even after being closed and opened.

    Could there be an issue with the crossfade click type? I want the menu to instantly appear, so I guess I could run an action to just close the pause menu and open the options menu and force the first selection in there. But maybe there should have been another click type, like "instant"? The options menu has no transition, but there is still a moment where the pause menu disappears and the options menu appears - also, you can briefly hear the audio popping in and out as the game briefly unpauses and pauses again. I will try the actionlist workaround and see if that works, but maybe there are some refinements to be done here.

    EDIT: The actionlist method works (a simple actionlist that turns off Pause, turns on Options, and selects first visible element). There's still the tinyest of audio pop though between the two menus, but that's a minor niggle.

  • The audio-popping should be removable with the right ActionList properties, but try simply swapping the menu states around so that Options turns on before Pause is turned off. Does that sort it?

  • Unfortunately not, there's still popping with Options turned on first. Both the music and SFX are playing for a split second.

  • What of the ActionList's properties?

  • They are set to Pause Gameplay. I tried Disabling the Unfreeze pause menus, that appears to have fixed it. Will try to edit the rest of the menus and report back if there's still an issue.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.