Forum rules - please read before posting.
Tech questions during the weekend? Drop in on the community Discord channel!

Bug? Hardware main cursor does not display in pause and/or doesn't properly swap between cursors

Last months, I used AC's Software cursors without any hiccup.
Recently though, my webgl export no longer hides the system cursor and displays both the system and AC's cursor with Software cursors enabled.
So I started switching over to Hardware cursors (which fixes the double cursor), but I now encounter some different cursor issues in Hardware mode, which I couldn't find a solution to in other forum posts:

My settings and test scenarios:
1) Cursor rendering set to Hardware with and without unity ui prefab cursor script (https://adventure-creator.fandom.com/wiki/Unity_UI-based_cursor)
2) 'Directly-navigate Menus when paused?' = OFF
3a) Main cursor settings: Display cursor = Always
=> main cursor visible during gameplay, main cursor hidden during pause
3b) Main cursor settings: Display cursor = Only when Paused
=> main cursor hidden during gameplay, main cursor visible during pause
Weird.

It becomes even stranger after some further testing:
4) Main cursor settings: Display cursor = Always + Animate? = ON
=> above 3a/3b scenario's
=> main cursor switches normally between Main and Interaction icons

5) Main cursor settings: Display cursor = Always + Animate? = OFF
=> main cursor is visible during gameplay AND during pause
=> But main cursor does not switch properly between Main and Interaction icons

Further details:

  • original issue with Software double cursors tested on Windows Chrome, Edge and on Mac Chrome and Safari
  • tested with Unity 2019.4.17f1 and 2019.4.18f1
  • tested with AC version 1.73.0 and 1.72.4
  • tested on Windows and on Mac platform
  • same results in editor and in webgl export
  • Main cursor = 1 frame, import settings set to: Cursor
  • Examine cursor = 1 frame, import settings set to: Cursor
  • All other cursors: 4 frame animations, import settings set to: Cursor.
    So I don't actually need the Main/Examine cursors to be animated, but if I don't enable that option, the cursors don't swap properly depending on different hotspots. They get stuck displaying either the previous Hotspot's cursor state or the Main cursor.

What am I doing wrong here or is this a bug? :)

Comments

  • The original Software issue is most likely by design on Unity's / WebGL's part.

    3a) Main cursor settings: Display cursor = Always
    => main cursor visible during gameplay, main cursor hidden during pause

    I can't reproduce such behaviour.

    You mention testing with/without the Unity UI cursor script. Let's stick to without for the moment, as that script is not an official part of AC. Are you getting the above behaviour without it?

    But main cursor does not switch properly between Main and Interaction icons

    How/when the cursor changes to interaction icons depends on many settings besides those you've shared.

    There's a lot going on here. The best way forward would be to create a .unitypackage file of your Manager and cursor graphic asset files, then PM it to me along with a list of steps on how to recreate your issue(s). That way, I can be sure to be properly recreating the same issue you're experiencing.

  • I can't reproduce such behaviour.
    You mention testing with/without the Unity UI cursor script. Let's stick to without for the moment, as that script is not an official part of AC. Are you getting the above behaviour without it?

    Yes, without the script same behaviour as well.

    How/when the cursor changes to interaction icons depends on many settings besides those you've shared.

    I think I found the solution:
    I had the default Examine interaction enabled for all my hotspots.
    image

    When I delete that and replace it with the newly added Use interaction (with Look icon, top screenshot), everything seems to be fixed.

    Seems odd that this caused such behaviour, as I thought below option had everything covered:
    image

  • The pause issue is still occuring, I take it?

    I still don't have enough to go on. Please consider my request above about preparing a package that I can use to test with.

  • Glad to say that all issues were resolved by removing the default Examine interactions and replacing them with Use interactions.

    I no longer have the pause issue either, as I can leave the Main cursor's "Animate?" option unchecked now, as it should be in my case.
    Since I have a one-frame Main cursor, that probably caused it to disappear in pause state, but I was getting confused as it seemed to fix my cursor toggling issue at first. :|

    Let me know if you'd still like to investigate my manager and asset files to recreate the issue.

  • I would if possible, yes. I'm not sure I quite follow all the settings involved, but if you have to change your Hotspot settings then it doesn't sound like things are working as they should.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.