Forum rules - please read before posting.

Video skipping direct to scene switch

Any idea why this just skips the video and switches scene?
When i take away the scene switch it works fine



  • http//

  • What are your AC and Unity versions, on what platform, and is this in builds/editor only?

    Is it possible the "Skip" input is being invoked at the time? What is the effect of disabling the ability to skip?

    The Video Player is set to render to a Render Texture, but no texture is assigned - is it your intent to play the video through the camera? Try setting the Render Mode instead to Camera Near Plane.

    Try also assigning the video clip asset in the Action.

  • Windows 7
    Unity: 2019.4.28.f1
    AC: V1.73.6

    Builds and Editor issue.

    The issue still occurs when I disable ability to Skip

    When I updated to this version of unity - the current video format i had working before (H264) wasn't supported so i had to change it to VP8.

    See attached,
    For some reason it just ignores the WaittUntilFinish method. If i place a 'Engine wait' after the movie script, it will play for that amount of time then skip scene.

    see img


  • Are you saying that this was previously working with an older Unity version / different format?

    I cannot recreate such an issue. Do the Video Player component's Wait For First Frame and Skip On Drop options have any effect?

    Try duplicating the Action, so that the video is played twice in succession, but uncheck Wait until finish? in the first Action.

  • edited June 2021

    I unchecked Wait For First Frame and Skip On Drop. This did the trick

    thanks I appreciate it

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.