Forum rules - please read before posting.

Autosaving error

I ran into an error when trying to call an autosaving cutscene from a trigger:

For your reference I am using choose interaction then hotspot mode.

The autosave does run correctly, and the game is saved, but several other things happen- First, the cursors disappear. Cycling through the cursors does nothing, and clicking on any spot in the game will cause the player to walk there as if the walk cursor is selected, but no other cursors can be selected.

Second, the interaction menu disappears. In fact no menus appear at all. Including speech subtitles. So effectively the game stops working as intended. Menus are no longer called and no other interactions besides the walk interaction can be used. Cutscenes are still appropriately run but the speech/other menu actions are not shown.

I am using Unity 5 and AC 1.43a.


  • And you're sure it's the Autosave call that does this?  Removing that one Action from your Trigger prevents the problem?

    Try running the 3D Demo's Basement scene with the 3D Demo Managers, except your own Settings Manager.  When the opening cutscene finishes, the game autosaves.  Let me know if the problem happens again or not - it'll help pin the source of this down.
  • I tested it in the demo scene and in one of my other scenes and it seems to work fine.

    I should probably elaborate on the trigger and the scene I'm in: 

    This is my big terrain scene, and I have many triggers which move the player from one "scene" to the next, and I set up one single cutscene with many parameters to call over and over again using these triggers. I tried running the autosave after in that cutscene, and that is what caused the problem.

    This error does continue to happen when I have the autosave running after that "change terrain scene template" cutscene. 

    I did however just try adding another parameter to check for "Autosave?" and then run a second cutscene which performs the autosave, and this seems to work, so it must be due to the length of the cutscene on which it was used? Or maybe since there were 9 parameters in that cutscene that caused a problem? Any idea?
  • From the bottom of the Settings Manager, you have a debug option to show the active ActionLists in the Game Window when running.  Use it to see if anything else is running at the time of the AutoSave.
  • I did that previously and the only actionlist running was the 9 parameter cutscene called by the trigger interaction. 
  • Is your Trigger set to wait until the Cutscene has finished running before ending it's own list?
  • edited April 2015
    No it is not. The trigger actionlist has one action which ends before the cutscene has finished. Here's a screenshot of the trigger action list: 


    And here is the cutscene it calls (keep in mind I have disabled the autosave for the cutscene and replaced it with a call to a new cutscene if the trigger calls for autosave, this is how it currently works correctly. The error occurs if I check "autosave after" in this cutscene inspector:

    (this picture is much taller so I won't embed it)

    Like I said, I have it working using a different (and better) method so if you can't recreate this then we'll just assume it's a weird quirk with my setup, but if you need any more info let me know.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.