Forum rules - please read before posting.

A couple of newbie issues with 2.5D tutorial

I'm having a couple of issues with the 2.5d tutorial. The hotspots are appearing twice in each camera view but they work as expected, it's hard to describe. it looks as though one is floating above the other.
The second issue is that when i apply root motion in the animator configuration box the girl character won't move at all. With it off she will slide around.

Any help would be appreciated
«1

Comments

  • Welcome to the community, @tedster.

    We'll need a bit more info about both of these issue in order to best help, I'm afraid.  If you can post some screenshots that show them via e.g. imgur.com, that would be great.

    Hotspots can be limited to a specific camera by assigning that camera in the Hotspot's Limit to camera field.

    For the animation issue, is the girl still animating - but walking on the spot?  It may be something to do with her animation import settings, rather than AC.  Have a look at the way her walking animation is set up in the FBX import panel that you get when selecting the model file and viewing the Inspector window.
  • Thanks for the response Chris, Great job with the software btw. 

    Here is a link to an image that shows the hotspots -> http://imgur.com/a/9j0fV  . The one you see at the bottom and in the middle of the screen are actually the same one. when the game runs you can actually only click the lower one and it plays as expected. They're already limited to a single camera so they work as expected, it's just when placing them it is difficult because I'm seeing double, it almost looks like a camera effect. 

    The Girls idle animation is running over and over, She will rotate to point in the direction of my click but won't actually move. I've connected the animations together and used your speeds etc
  • Ok I got her to move around, I hadn't labeled 'MoveSpeed' the same in both the animator and the inspector. Although I can see that each animation is running now , she's still sliding along the floor. I'm guessing I've made another simple mistake somewhere. I'll keep at it.
  • Hotspot issue:
    Are you sure it's the same Hotspot?  If you move it along sideways, do both boxes move?  We'll need to see a couple of shots showing how it appears in the Scene window, and it's full Inspector.

    Animation issue:
    Sliding when the animation stops, or does the walk animation play when it shouldn't?  It may be a case of playing with AC's movement fields (Acceleration, Walk speed, etc), but first do check that everything runs correctly in the model file's Animation panel.
  • http://imgur.com/a/h8l8G

    Yes I move one and the other moves also at the same time. There are 2 hotspots sitting there, one for entering the steps and one for entering the waterfront but if you look at the second image you can see the plaza hotspot also. Its set to plaza cam only. Perhaps its my version of unity? 5.5

    The animations play in the animator preview but the character will only really move when i make her run, she kind of stutters along with no animation playing at all so I think you might be right with about the acc, speed etc. I can see them playing in the animator window when the game is running when I click walk or run but shes actually just sliding along the ground with no animation.

    when I click to walk I can hear the footsteps SFX playing but she doesn't move. When I click to run she slides in a jittery way. I've tried both a character controller and a rigidbody+capsule collider.

    Thanks for your help, I've probably done something stupid
  • edited February 2017
    The two Hotspots are separate GameObjects - you can see that they're named differently (one is "Waterfront -> Steps", the other is "Steps -> Waterfront").

    Did you parent one to the other?  Where do they appear in the Hierarchy?

    Re: Animation issue - there does seem to be an issue when working in Unity 5.5.  If the Animation state is playing in the Animator, but it's not having an effect, it could well be a bug with Unity itself.  I'll look into it and get back to you - thanks for the info!
  • edited March 2017
    The tutorial files need to be updated for Unity 5.5 compatibility.  You can try out a newer version here:

    http://adventurecreator.org/files/TutorialFiles5.unitypackage
    http://adventurecreator.org/files/TutorialFiles55.unitypackage
  • Hello there, I'm sorry to tell you that I've the same identical problems with Unity 5.5, but I've finally solved the 2nd one:
    I managed to have working animations just getting the right tutorial asset, there is a mistake in the tutorial filename.
    The correct one is


    Using this file mecanim works without problem.

    @ChrisIceBox please update this link and the link in the tutorial page.. I passed last 2 days making tests trying to understand what was wrong.

    About the first problem (gizmos visibility in the game window) the only workaround I found is to enable the camera. When the camera is enabled seems that gizmos is correctly visualized; when is disabled, instead, seems that all selected logic (triggers, hotspots) is visible on the game window.. all together.

    I hope that this will be useful for someone else.

    As usual, I apologize for my English.

    Regards.
  • Sincere apologies, @StevenP94 - I've corrected the links.  Sorry for the hassle, and I thank you for making me aware.

    Which camera are you referring to, the GameCamera?  It may be that this is tied to a bug within Unity.
  • edited March 2017
    Thanks for the quick update, @ChrisIceBox
    I'm following your 2.5D tutorial and all the GameCameras (plaza, office, steps, water) has this problem.
    The gamecameras when the camera component is disabled, show in the game window all the logic components, regardless if they are behind the camera or not. In this way is very difficult to understand where a trigger or an hotspot is really placed.
  • edited March 2017
    Recreated, thanks.

    This indeed looks like a bug with Unity - if you try the same thing in an earlier version (I tested 5.0.1), no such issue occurs.  I shall see if a workaround can be found.
  • Update: try reducing the Near and Far Clipping Planes of the Background Camera to their minimum.

    It seems the logic components are coming through to the Background Camera (which they shouldn't be, as the layers do not match the culling mask).  Let me know if that works, and I'll update the prefab.
  • Seems that setting the Background Camera clipping planes near to 0.01 and far to 0.02 and enabling the camera fix the issue.
    I'm not 100% sure because my tutorial was in advanced state so I have a lot of triggers and hotspots and this is a bit confusing.
  • Thanks for the info.  The BackgroundCamera should be enabled by default - what is the state of the original prefab?

    Apologies that this is a confusing issue - my opinion is that this is a bug with Unity, but it should have been accounted for sooner.
  • The original prefab is enabled.
  • edited March 2017
    Specifically, I meant the Camera component of the original prefab - if it's enabled but the one in your scene wasn't, did you manually disable it?

    Just trying to work out the situation as fully as I can.  If the BackgroundCamera's Camera component is disabled, the BackgroundImage won't be visible - either in-game or when working in the Editor.
  • I specified 'enabling the camera' because I made a lot of experiments with cameras, enabling and disabling the Camera component and other cameras has the Camera component disabled so I reported, just in case.
  • That's fine - just wanted to be sure it wasn't AC that was doing it, as the fix will involve updating the prefab.
  • Wondering if you've found a work around for the double hotspot issue.  I've only added 1 hotspot and it appears as 2.  I've left the hotspot in a position so you can see the markers on each one.  Let me know what settings I can use so my window doesn't get filled up with twice the number of hotspots as I move through the tutorial.  

    Thanks!

    image
  • IIRC this is down to a bug with Unity, which AC now compensates for with updates made to its prefabs.  Not sure why it's occuring for you now.

    Try following my suggestions above regarding the near/far clipping planes of the BackgroundCamera, and enabling its Camera component.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!