Forum rules - please read before posting.

Nintendo Switch startup problem

hi. I have a problem when adding Adventure Creator to my project then the project crashes at the very beginning of starting the app only in the switch platform. no splash screens showing. just crashes when launched. I tried to disable the save system or anything but no luck till now.


  • I should preface this by saying the Switch isn't an officially supported platform.

    You mention disabling the save system - is that due to having scene this thread?

    What is your AC version, does the issue occur if you set your Build Settings first scene to a non-AC scene, and have you tried forcing saving to PlayerPrefs, as going by my third comment in the linked thread?

  • edited April 12

    thanks for the reply
    I'm using the 2022.2.14f1 version of Unity and the latest version of Adventure Creator.
    yes, I've set build setting first scene to an empty scene and still, It crash at startup. even the splash screen does not show "made by unity" or any other. just crash when touch the game. only if I added adventure creator to the project even an empty project with added ac files (not added anything to any scene just files in the project imported), then it crashes at clicking the game icon instantly.
    and yes about the save system. I disabled it in persistentengine prefab and changed some codes about saving. but i think it's something related to initializing AC in the background that causes the crash.

  • AC won't initialise until the first scene that has a GameEngine object present is opened. You can double-check this, however, by removing the AdventureCreator directory from your Assets folder.

    Does this occur when building to Desktop, and are you able to get hold of Unity's Player logs for this application?

  • edited April 13

    for desktop and Android fully working without crash, just for switch. when removing the adventure creator folder from the project then it works without problem.
    and for the save system yes I have done what you suggested in your third comment but still crashed instantly after opening the app. just one empty scene just camera and light. nothing from ac.

  • Any luck with the logs? Obtaining them will be the best way to get to the bottom of this.

    Rather than uninstalling AC completely, strip it down by removing the Demo and 2D Demo folders if they're present.

    If it still fails, try stripping away the contents of the remaining AdventureCreator/Resources folder. The only file strictly necessary for AC to run - provided Spawn PersistentEngine from Resources? is unchecked, is the References file.

  • edited April 14

    thanks for the advice. the problem is with the script folder. now working and testing on some files in the scripts so I hope I can find what is the the crash reason.
    because the scripts need each other to call functions I can't delete them one by one to find out what causing the problem so it's very hard to find. I don't know how other guys managed to work with it without any problem on the Nintendo switch

    Unfortunately, I cannot get the log due to hardware problems

  • See if it's related to the AC.asmdef file inside the Scripts folder - it may need updating/removing for Switch builds.

  • thanks a lot for your reply. but there is no such file in this directory. searched in all directories but can't find such file with this name and extension. i know its a big request but if you have a custom package with this modifications for switch (like changed or removed savesystem or ...) if its possible send for me to test it because its a lot of files here to check and unfortunately I cant use log. thanks

    and if there is another suggestions to test tell me to do. thanks a lot

  • edited April 15

    It's a file that was introduced in v1.80.0, and should be in the Scripts folder - not any of the sub-folders.

    How did you determine that the problem is in the Scripts folder?

    Is this a case of importing AC into an existing project? Try importing AC into a fresh project - excluding the Demo and 2D folders - and building it with just an empty scene assigned as the default in the Build Settings.

  • hi. thanks a lot
    I removed all other folders one by one and tested, after all, I deleted all except scripts, and then only the scripts folder remained and caused the error.
    and for the fresh project, I tested all scenarios and there was no luck. just I thought if it's possible to test a little customized AC version by you. thanks a lot have a good day

  • For the fresh project, did you make the change I mentioned in the other thread regarding the SaveSystem file, i.e. replacing:



  • yes. I've made those changes in a fresh project plus a few other changes but still no luck.

  • Sorry to repeat, but to be super-clear: this is even when the only scene in your Build Settings is an empty, non-AC scene - so that no AC objects are present or referenced?

    It sounds like this may be an issue with Unity in that case, as the presence of unreferenced scripts shouldn't affect a build once compiled.

    I'd recommend trying the latest 2022 LTS version, and tinkering with the "Configuration" fields in your Project -> Player Settings, that relate to the various scripting version / API levels.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.