Forum rules - please read before posting.

First person camera moves at the same speed at all times regardless of mouse movement.

Hello again. I don't know if it's because of a version difference, but after following the First Person tutorial, I have a walking first person player, the cursor is togglable, the camera moves, but it seems to only be able to rotate at a single speed, regardless of how I use the mouse. (wether I move it slowly or quickly, the speed is the same). I tried changing the camera settings and movement settings (like the acceleration) but didn't manage to fix this. It's probably something I overlooked again but I have no idea what.


  • What's your AC version and "Input method"?

    Input speed should be based on the input settings defined for the "CursorHorizontal" and "CursorVertical" inputs - how are these set up?

  • Ah I thought I had the latest version but there was another one recently I missed.
    Also, now instead of creating new inputs, I replaced the existing Mouse X and Y with the Cursor inputs. It works now so I think it was the default input settings doing that.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.