Forum rules - please read before posting.

Console errors when updating AC from version 1.72.3 to 1.72.4

edited January 2021 in Technical Q&A

Hello AC community!

Currently using Unity 2020.2.1f1, with Adventure Creator 1.72.3.

Am getting the following console errors when updating AC version 1.72.3 to 1.72.4:

I was originally on Unity 2020.1.5f1. Then updated to 2020.1.7f1. Then updated to 2020.2.1f1 (latest Unity version) after that. After each Unity version updated, I attempted to update AC from 1.72.3 to 1.72.4, on each. Each time it returned the same console errors.

A backup of the project was made of course, so can still continue to use 1.72.3 for now. Though with 1.72.4 these errors will not allow a build of the game (or even preview).

Am wondering, would it be best to just wait until the upcoming AC 1.73 release, which I've seen in the "Official News" category forum is being planned for a release soon?

Looking for assistance on this! Thank you very much for any support that can be given! It's appreciated!


  • Going only by the screenshot, it looks like you've only partially imported AC into your project - perhaps only the new files have been imported, while existing ones haven't been overwritten.

    Assuming you've backed up beforehand, try removing the AdventureCreator/Scripts subfolder and re-import from Unity's Package Manager. I've heard tell of issues with importing assets in particular from the Package Manager.

  • edited January 2021

    Thank you for the tips!

    only partially imported AC into your project

    Sounds like that's potentially what may be happening. Have been using AC for a while now though, and I always just import everything as it is set in the "Import Unity Package" window -- except for unchecking the "References.asset" each time. Has worked great up to now for the most part.

    In any case, tried removing the "Scripts" sub-folder which seemed to remove most of the errors.

    One error remains still:

    Looks related to VR, though the game / project is 2D, using Sprites Unity Complex. Wondering if further assistance can be provided in how to go about solving this remaining error.

    heard tell of issues with importing assets in particular from the Package Manager.

    Regarding the Package Manager -- It seems that's the only way to import now, from my understanding. The "Asset Store" tab in Unity now re-directs to and opens the Asset Store in a browser. When clicking "Import" in the browser Asset Store, it re-directs to and opens the Package Manager for importing.

    Also, a couple of other interesting findings (just to provide as much info as possible):
    I noticed in the latest working "backup" of the project, under the "AdventureCreator" folder in the "changelog.rtf" file shows 1.72.3 (like it should).

    However, in the project I attempted to upgrade and imported the downloaded 1.72.4 package into, the "changelog.rtf" file reads 1.70.2, for some reason (and the manual PDF does too).

    Here's a screenshot showing the current AC version downloaded in the Package Manager, though (1.72.4):

    Is there a possibility that's why some AC files are only partially being imported, and reason for console errors?
    Perhaps the downloaded version in Package Manager is actually an older version somehow? If so, is there a good way to delete the downloaded version from the local computer hard drive, and re-download fresh again?

    Thank you for any further assistance!

  • The error message you're getting from the MainCamera script shouldn't be present if you've got the latest version - v1.72.4 specifically addressed an issue to do with this error message when using Unity 2020.2.

    You can fix it manually by commenting out the "#define ALLOW_VR" line at the top of the script.

    Perhaps the downloaded version in Package Manager is actually an older version somehow?

    If that's the case, then the issue lies with Package Manager. It may be a duplicate of this issue.

    It may be worth removing your cache of asset downloads - see this thread - and then downloading AC again.

  • edited January 2021

    Thank you for sharing that.
    The first link indeed seems to be what's happening.

    Think I'll just wait for Unity to fix the Package Manager bug before attempting to update AC again. From reading that thread, it seems they're aware of the bug and are looking into it currently.

    If the new fix they implement doesn't solve it, then will probably go the route of removing the old download cache, and re-downloading the newest version package again -- as from reading that same Unity forum thread it sounds like that also works as a work-around.

    Thanks for helping narrow it down.

  • edited February 2021

    Just wanted to add an update on this:
    The recent released version of Unity 2020.2.3f1 appears to have fixed this bug.
    According to the Unity forum thread mentioned previously, the Package Manager bug is fixed from that Unity version.

    At least, after updating to the newest AC version (1.72.4), and some testing, Package Manager appears to be fixed for AC asset updates.

  • Thanks for the update, good to hear!

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.