Forum rules - please read before posting.

Crafting recipes- When click on result: Run Actionlist does not work.


I'm currently running Adventure Creator v1.73.7.
All is well but I have noticed a problem with Action lists refusing to play under the "When click on result" option within crafting recipes. For the life of me I can't even get it to play a simple action list with a single sound clip.

"Just move to inventory" & "Select Item" are still working as intended...

but Action lists are still refusing to activate upon clicking.

As an example of what's exactly happening I made a simple recipe that takes this party hat item and turns it into a "Missing Item" placeholder. Upon clicking the Missing item placeholder it simply moves it into the inventory, similar to the "Just move to inventory" option, but it does not activate any type of action list even when a proper action list has been assigned to it.

In this instance I'm simply trying to get Adventure Creator to quit out of the game using the click on result, and I have also tried changing some properties on the action list itself using both "Pause Gameplay" and "Run in Background" but still no luck.

I can't come up with a solution myself other than a problem with Adventure Creator itself, or my own misunderstanding of what this option does. I'd assume since the "Just move to inventory" & "Select Item" options work upon clicking the crafted item that an action list would too.

Thankyou for your time.


  • Thanks for the detailed explanation of the problem.

    I've attempted this myself, and am getting a red error in the Console at the moment I try to transfer the item - is this the same for you?

    A potential fix: open up MenuCrafting.cs, and find the code block:

    case OnCreateRecipe.RunActionList:
        KickStarter.runtimeInventory.PerformCrafting (activeRecipe, false);
        if (activeRecipe.invActionList)
            AdvGame.RunActionListAsset (activeRecipe.invActionList);

    Replace it with:

    case OnCreateRecipe.RunActionList:
        ActionListAsset actionList = activeRecipe.invActionList;
        KickStarter.runtimeInventory.PerformCrafting (activeRecipe, false);
        if (actionList)
            AdvGame.RunActionListAsset (actionList);

    Does that fix the issue on your end?

  • edited May 2021

    Thankyou so much for the quick response!

    I did not receive a red error, the action list just refuses to play when it's told to but the change in the code seems to have fixed the problem on my end. Clicking on the crafted item now plays the action list it's assigned to and moves the item into the player's inventory, so it's working exactly how I imagined it should. ;)

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.