Forum rules - please read before posting.

Lighting issue when switching scenes

I'm having an issue that sort of seems like the lighting isn't fully working when I switch scenes. I've tried having no fade out from the scene before, and with the fade out, and it nearly always happens.

I'm using a hotspot over portals/objects, with Camera>Fade>Fade Out and then Scene>Switch and nothing extra added in.

Example, loading the scene with the proper lighting, going into the next scene where the lighting doesn't come on properly

And the other way round, starting in the second scene with proper lighting, going into the first scene where the lighting doesn't load - and then the odd exception where the lighting isn't broken going back to the first scene

It's not even as if it happens every time, as evidenced by the second gif. I'm at a loss for what's wrong.

I copied the process exactly from the Unity Adventure Game version of the tutorial, and it worked on my last project and sometimes works in this one.


  • Update: fixed. I don't know how. At some point today, when I'd opened and closed it a couple of times while working between this and another project, it fixed itself!

  • Welcome to the community, @thegamesheplays.

    AC doesn't get involved with lighting/rendering - Unity is still in control of the way scenes are lit.

    This behaviour typically occurs when your scene lightmaps are set to be generated automatically - as set at the bottom of the Lighting Settings window. Manually baking your lightmaps should prevent this - but you should also find that the behaviour is limited to the Editor only.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.