Forum rules - please read before posting.

endCutscene button causes Menu to never turn off when scene switches

Hi all!

Hope you are doing well!

I have a menu that is supposed to turn on for a short period of time (2 second transition time), and then it turns off immediately.

The issue is that when I press "c", which is mapped to the endCutscene action, it looks like if I switch scenes while the menu is still on, it never ends up turning off.

For reference, I have an actionlist that turns this menu on (with transition + wait till finish checked), and then it turns off (with transition + wait till finish checked).

Is there any way I can prevent this behavior? This only happens in between switching scenes when I press "c"; otherwise, the menu turns on and off as expected.

Any guidance would be appreciated, thank you!



  • If I'm following you right: this is a case when you have two ActionLists running at the same time? One that turns the Menu on/off, and another that ends with a scene-switch.

    It may be that the scene-switching ActionList is being skipped first - ending the other one prematurely.

    If you'd always like this Menu to be hidden after any scene-change, one way around this would be to use the Events Editor to create a new Scene / Change / After event that runs the Menu: Change state Action to turn the Menu off.

  • Yes!
    Ah I think that worked -- thank you so much! :)

  • edited April 25

    I also noticed another issue -- when I press "c" on an actionlist that is not skippable and the gameplay is paused for it, it looks like it starts that actionlist over from the beginning -- might this somehow be related?

  • This seems to happen when a camera is fading in or out -- but can't tell if it's happening otherwise.

  • I can't reproduce that behaviour - what are your AC/Unity versions, is anything else mapped to "c", and are any other (skippable) ActionLists running at the same time?

  • No it's just mapped to endCutscene -- my AC version is v1.79.0 and my Unity version is 2022.3.15.f1.

    That is the only one that's running.

  • I'll need a breakdown of the steps needed to reproduce the issue, from a fresh scene, in that case.

  • @ChrisIceBox Would it help if I give you permissions to my repository? I can go ahead and DM you the link -- it's the same one you may have accepted as earlier.

    Also it looks like if I press "c" too quickly when skipping the cutscene on the bulb - lamp interaction (in the deeper forest) -- it increments the bulbSequenceValue variable twice instead of once.

    So the lamp is showing up as fixed when 2/3 bulbs are added instead of all 3.

  • The lamp interaction happens in the dark forest, with the broken light post.
    The cutscene restarting issue happens in the parlor, after you have finished the lamp post fix objective.

  • I can download the repository, but I need to know the exact steps to see the issues, in a very clear way - i.e. open this scene, run this ActionList, press this button, check this window etc.

  • @ChrisIceBox Yes sure!
    I went ahead and bumped the repository link from an earlier DM

    As for the steps to reproduce:

    Parlor Issue:
    1. Set the "Make sure the lamp post is running"objective to be "Complete".
    2. Head to the Parlor / Mansion interior.
    3. After the blue-ball / ghost goes through the parlor, press "c" repeatedly -- the cutscene will replay occasionally -- you can also press "c" after the camera has panned back to the main character.

  • Lamp Issue:

    • Set "Carry Bulbs on start" to true.
    • Head to the Dark / Deeper Forest ( rightmost scene in game)
    • Use the bulbs on the lamp the first time and repeatedly press "c"
    • Use the bulbs on the lamp the second time and repeatedly press "c" -- the lamp will show up as "fixed" even though the last bulb has not been put on yet. This does not happen when I do not press "c".
  • I've recreated the Lamp issue, but not the Parlor issue. Pressing "c" has no effect on my end. Did I miss a step?

  • edited April 28

    @ChrisIceBox that one is a bit flaky -- I've noticed it happens sometimes, and other times it doesn't. Unsure what's different in each iteration.

    Might you happen to know what may be causing the lamp issue? Tried to do a bit of debugging myself, but I'm unable to figure out what's going on.

  • @ChrisIceBox Ah ok just tried it out on my front -- one instance where it's happening is when I press "c" _only after the camera has panned back to the player _-- so after the line "what was that?!" plays.

  • For the lamp issue, it's a case of the variable not being reset before it is re-run as a result of skipping.

    To fix: add the following to AC's ActionVarSequence script:

    public override void Skip ()
        if (runtimeVariable != null) runtimeVariable.RestoreBackupValue ();
  • @ChrisIceBox Thank you, will do! :)
    Will update the thread once I have done so --

    At your convenience, are you able to see the parlor issue? Wondering if you can recreate it on your end, or if you prefer a video of some sort! :)

  • edited April 28

    @ChrisIceBox also yes looks like that fixed the lamp issue, thank you so much!

  • are you able to see the parlor issue?

    Sort of - I can get the "What was that" line to repeat if I press "c" at this time.

    One thing I'm noticing is that many of your ActionLists end with an ActionList: Run Action with Wait until finish? checked. As these are the lasts Actions in the list, this check isn't necessary - but causes the list to remain "active" while the ActionList it runs if playing.

    Try unchecking Wait until finish? at the ends of the scene's AmeliaIntro and GhostMovement cutscenes.

  • Ah thanks, I think that worked!
    Might you happen to know why the Wait until Finish was causing the repeat, out of curiosity?

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.