Forum rules - please read before posting.

Right-click to drop inventory while inventory box is open?

Title -- is it possible to have the "right click to drop inventory" functionality when the inventory box is open?
It looks like it works fine apart from this, but I was curious to know if this is possible when the box is open.

Thank you so much!



  • It's a subtle difference, but is this actually a case of the pointer being over the menu? If it's rendered with Unity UI, then right-clicks are "consumed" automatically, IIRC.

    If you define an input named "InteractionB" and map it to "mouse 1", however, than that should be recognised even in that instance.

  • @ChrisIceBox Is this correct? I went ahead and tried this, but it doesn't seem to work still.

  • edited May 17

    And yes it's being rendered through Unity UI!

    This is what i have checked off btw:

  • Is this specifically when the mouse is over the menu, and what is the result of mapping the input to a keyboard key, e.g. "2" - does pressing "2" deselect the item?

  • Yes it's when it's over the menu (any part of the screen when it's open because there is a huge "amost invisible" panel behind the menu when it opens up that acts like a close button.
    No mapping it to 2 doesn't work either.

  • However. right clicking does work when the menu is open and I'm on top of a filled inventory slot.

  • I noticed this also happens when my dialogue box is open (but that's not an issue).
    It looks like this occurs when the menu open has "pause game" set to true?

    I wonder if there's a way we can somehow bypass this functionality -- but the strange thing is when my dialogue box is open, using "c" to endCutscene works fine (which is another input that is defined).

    It's just the right click that doesn't work.

  • I can only recreate insofar as a right-click not working - but mapping InteractionB to another input works on my end. Is "2" deselecting the item when not over the Menu?

  • @ChrisIceBox 2 works when it's not over the menu!

  • Recreated - thanks for your patience.

    I will look into this.

  • Awesome, thank you so much! :)

  • Yep, this'll be fixed in v1.81 - thanks for the bug report.

  • edited May 22

    Awesome! Thank you! :)

  • @ChrisIceBox Just pulled down the most recent update!

    I think I'm still running into the same issue (all the links in the above thread is still in the same context)

    One thing is I beta-tested v1.81 through a downloaded package you sent earlier, so not everything got imported through this time around:

    In "scripts", the only file that was imported this time as the AC asmdef file.

    I also deleted and redownloaded AC but still ran into the same issue.

    I also tried adding the "InteractionB - mouse 1" in the player input (and tested without it), but that also didn't work.

    With that being said, I was curious to know -- is there a way I can check where this change has been made in the package?

    I was just wondering if it's something that is still persistent, or if it might just be an issue with how I updated.

    Any help is appreciated, thank you!

  • Seems like an issue with the import - a fair number of changes were made to the Scripts folder since that test. The Manual and Changelog files have also been updated.

    With v1.81.0, an "InteractionB" input should not be necessary.

    To check if you have the correct import, is the Manual's front page listing v1.81, and do you have the Use invariant culture for saving? in the Settings Manager's "Saving" panel? That was a feature added since the test.

  • Yes I have that!

  • edited May 23

    @ChrisIceBox Would it be possible to know where / what the fix was made for right-clicking when the inventory box is open? I can double-check to see if I have it -- if not, I could go ahead and just manually add it.

    I was wondering if I could just check to see if I have that -- I deleted the AC package and redownloaded / set my managers, etc. (so this forced it to reimport everything), but it still seems to not work strangely.

  • It wasn't a case of just one tweak, but essentially it boils down to the PlayerMenus script's new CanCurrentlyRightClick function - as called by the PlayerInteraction script - needing to returning false for it to be possible.

  • @ChrisIceBox So it looks like my PlayerInteraction script does not have any references to CanCurrentlyRightClick -- however, all the other updates in the changelog seem to be there, along with invariant culture for saving? as the sanity check.

    Might it be possible for you to check my latest repository to see what might be missing in order for the interaction to work?
    It's the same link as the one I DM'd you a short while ago! :)

  • The reference is there - you have the correct version.

    It looks like it's down to the Inventory menu pausing the game, which currently prevents the check being made. I'll look into this.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.