Forum rules - please read before posting.

1.34 Updated project problems :|

edited June 2014 in Engine development
So before updating to 1.34 everything was working perfectly in 1.33b. Oh man, i really really really dont want to fine tune anything at this stage of development.

Here are the list of things i seem to find

1) The dialogues in scenes seem to blankout though the actions after or before them seems to work. I got many cutscenes when character changes scene, he speaks something. Currently this does not happen.

2) When playing the preview, the cursor seem to go non resposive for several seconds when changing scene. Unless you drag the mouse out of the Game Preview screen and back in to it the cursor/mouse wont function.

3) There is a problem with the character and i dont quite know whether this is due to sorting map or pivot points of sprites or both of them combined.

When i click on a location, character moves and stops just 1 thumb up and right of the location. Its not just movement, playerstart positions result the same way. If i place player start on the door, character appears 1 thumb up and 1 thumb right of the location of the player start marker therefore looks like levitating or in the wall etc. I checked and the pivot points of the sprites are where they should be.

Also, characters size seems to be shrinked down sorting maps seem to cause character to either get too big or too small for some reason. Last but not least, the setgeometry layers seem to appear above the character on some locations (which were okey in previous version). I do know this is due to layer orders so im changing the values of the layers (mostly going -10 and down) but the sorting layer is not going below 5 in any layer orders. WHY does my character now gets under the layers with order of 1 and 0.

4) Turn on or off menus dont work in scene but affect the later scene.

I have Scene A and Scene B. In Scene A i turnoff all menus and in Scene B i turn them on one by one.  All of the menu_turnoff are done in the first cutscene and as the first jobs in the scenes.

After the update, The menus appear (they wont turnoff) in Scene A. But when you go to Scene B they appear turned off and they work normal.
If i change Scene A as in Locking on and off the menus. Then menus dissapear in Scene A but they appear in scene B.


Is my project corrupted? Does everyone else has the same problems? Should i download the asset again and re import it?

The last two of these problems might be resolved with fine tuning but adjusting them again are a huge amount of work and thats a problem for me. So much so its either starting from the blank (instead of jumping in to the current complicated structure) or reverting back to 1.33b. Which i rather not do and just wait for 1.35 update (or the next one after 1.34 if it fixes these problems.) .

Anyways, im looking forward to work with the new structure without the limitations of Menu and Inventory Action lists. Thanks in advanced


  • No need to panic.  It won't have been corrupted, and an update will sort it.

    There's quite a bit going on here, and it sounds very specific.  If you could, please PM me a project that demonstrates each of these problems (you can remove any unnecessary assets / scenes).  There's not enough detail in your post, and I think I'll need to see these problems for myself.

    Sorry for the hassle.
  • Hi Chris,

    I have the same problem as Harkenin (1) - Since update to 1.34, (all) text in game window suddenly disappear. Not just dialogues, but hotspot label too. Upgraded Unity to v4.5.1 and AC to 1.34b today, but problem still exist.
  • OK, couple of questions to help me figure this out:

    1) Is your PlayerMenus script on the PersistentEngine prefab?  (This prefab is instantiated at run-time)
    2) Do your menus display correctly in preview mode? (i.e. in the Game window when your game is not running)
  • edited June 2014
    1) Yes.

    2) Well, I was wrong - it's not true that "All text" dissapeared in game window. Actually, Menu is working OK. I'm still working on models & texture & animation for my game, so I only have one (test) hotspot and corresponding interaction for now. No menu yet. But, if I turn Menu Asset file to Demo_MenuManager, it's working.

    So, problem is in hotspot labels and dialogue.
    Here are two examples, for both problems:

    Pic. 1 - In AC version 1.33, above USE icon there was a hotspot label ("Dock gate"). Now it's gone.


    Pic. 2 - Dialogue action (for hotspot interaction) does not work in AC 1.34b. All other actions works OK. There is a few second pause in game after previous action (2:Object:Animate) so it's appears that AC IS executing dialogue action, but no text ("The dock gate is locked") on screen. Is it possible that this is a some kind of a font problem (font selection, size...)?


    And one question: Is it possible to change font and use background texture in dialogue (and narration) as it is possible in Menus?

    Thanks for this great creation kit!

  • It sounds like you're just not using a complete Menu Manager yet - the Menu Manager needs to contain Menus that display Hotspot labels and dialogue text for them to display.  The Demo_MenuManager has these built-in, so if you replace it with your own one you'll have to either copy them from the Demo asset or make your own.

    Once you are using your own Menu Manager, you can completely customise fonts and textures for all menus.
  • OK, I'll do it in next few weeks, and hope that this will solve the problem.
    I just don't understand why everything worked normally 'till last update.

  • Problem solved.
    Font (selection) is missing in "Interaction Menu" (1:Use - interaction element) in asset file Demo_MenuManager.

    Thanks Chris.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.