Forum rules - please read before posting.

[SOLVED] Bug: Cant add a new interaction

edited June 2014 in Engine development

I tried to implement a "Pick up" interaction in our game but couldnt't get it to work. I managed to reproduce this issue in the Demo game, so I guess this is a bug. I use Unity 4.3.4 and Adventure Creator 1.34b.

Steps taken to reproduce in Demo game:
1) Go to Interaction menu, choose Interaction element type and click new.
2) I call the new interaction Pickup and have the ExitLeft cursor just to distinguish it from the rest, other settings are the same as the other icons:


3) Then I try to create the new interaction on the worm, using these settings:

4) Now, when I try to save and run, the new interaction has not been added and the Pickup interaction has disappeared from the Interaction menu. And when I try to click on any of the existing Interaction elements (Look, Use etc) I get the following exception:

NullReferenceException: Object reference not set to an instance of an object
AC.MenuManager.DeactivateAllElements (AC.Menu menu) (at Assets/AdventureCreator/Scripts/Managers/MenuManager.cs:307)


  • This appears to be an intermittent issue - I was able to recreate it once, but can't again.  I've implemented what I hope will fix it in 1.35.

    In the meantime, you *should* be able to get around the NullReference exception by copying / pasting the broken Menu in question, then deleting the original.
  • PS, thank you for your clear explanation and steps to reproduce.  Other bug reporters, please take note!
  • edited June 2014
    Can confirm that the issue has been resolved with AC v1.35. I also upgraded to Unity 4.5.1 and have no problems so far. Thank you for resolving this so quickly! 
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.