Forum rules - please read before posting.

Inventory Interaction stopped working

Hey anyone. I've been working on my game. And everything was great until today. I took a few days because my work was really busy. But when I loaded up the game. Inventory Box in the Interaction Menu doesn't work anymore.

I have hotspots with Inventory set on them, I have picked up the inventory. But nothing shows when I'm interacting. This even includes a scene that I worked on older scenes. I've made 0 changes to the Manager prior to issue.

Does anyone have any ideas on how to correct this or what I could be overlooking?

Comments

  • There must have been some change to your game between when it was working and when it stopped working.  What version of AC are you using?

    If you're using a InventoryBox element inside an Interaction Menu, I'm assuming your Interaction method is Choose Hotspot Then Interaction, correct?  Make sure that Include Inventory items in Hotspot Interaction menus? is checked under "Inventory settings" in your Settings Manager.

    The default Menu system is configured to work this way.  Try switching your Menu Manager asset to Demo_MenuManager temporarily to see if it then works again.
  • Well, I couldn't find anychanges. But I used your suggestion to use the Demo_MenuManager which worked. So I just started working from there. I'm good now. Thanks for the tips. I'm still toddling around with this program.

  • edited October 2022

    Hi All,

    Unity 2021.3.1
    AC 1.75.8

    A little context upfront... I have started working on my my game again after quite a bit of time away from it. I updated to Unity and AC versions that were fairly far apart from the ones I had installed. It's been a bit of a mess getting things back to normal.

    One thing I cant figure out is why interactions on my inventory items dont work. I am using interaction, then hotspot. I cant use, look at, give, etc. I get the hotspot label in the inventory to show but when i click nothing happens, despite having action lists in place. My regular in-scene hotspots are fine, I can interact with all of those, its just my inventory items that dont work.

    Im sure there is probably something pretty basic Im over looking, any help would be appreciated, I've been stuck for a couple of sessions now. Screenshots below. I can provide more if required. Thanks Everyone.





  • I updated to Unity and AC versions that were fairly far apart from the ones I had installed. It's been a bit of a mess getting things back to normal.

    One thing to bear in mind when updating AC is the "Upgrade notes" sections of the Changelog file. This lists any changes made to a release that may affect the way your game behaves, i.e. changed settings etc. If you haven't seen them already, have a look through the sections between the versions you're updating to and from.

    I can't see any issue from your screenshots, however - what you're sharing look OK. We'll need to run a few simple tests to pin down whether this is a UI, settings, or ActionList issue.

    First off, try running the ActionLists involved manually at the time the Inventory menu is open. You can do this from the "Run now" button in their Inspectors.

    Assuming they run OK, try reverting back to the default interface. You can do this by temporarily assigning your Menu Manager's asset file to Default_MenuManager, from the top of the AC Game Editor window.

    The Inventory will then be accessible when the cursor hovers over the top edge of the screen. Are they then interactive?

  • Thanks Chris. Yes to both. I can run the action list manually while gameplay is ongoing and when I set the Menu Manager to default (and interaction setting to hotspot then interaction) I can interact with inventory items

  • and interaction setting to hotspot then interaction

    What's the result of using the default Menu Manager, but "Choose Interaction Then Hotspot" mode, which I gather you were using before?

    With this mode, the active interaction type can be set either by right-clicking to cycle through them all, or by clicking "Interaction" menu elements to set them directly. Which method are you using?

    If this mode works, let's see how the Inventory menu works with the rest of your interface:

    • Copy the default Menu Manager's Inventory menu
    • Re-assign your Menu Manager back to your own
    • Select your Inventory menu and check Start game locked off?
    • Paste the default Inventory menu into your Menu Manager, and move the Hotspot menu down so that it's underneath it

    What's the behaviour then?

  • No change unfortunately. The default inventory shows up at the top like in the 2D demo, but when I interact, then select the inventory item, nothing happens.

  • Was the previous test I mentioned of switching back to Choose Interaction Then Hotspot successful? I'm trying to single out the specific part of your game that's causing the issue.

    If things work when the default Menu Manager is used, but not when the default Inventory menu is used in your own Menu Manager, then it may be a case of another Menu blocking it. Could this be the case?

    It'd be worth trying the reverse, i.e. running the 2D Demo game with your own Menu Manager assigned (but the 2D Managers for all others), as well as your own Inventory menu copied into the 2D Demo's Menu Manager.

    Are you using Unity UI or Adventure Creator as your Menu sources? You're welcome to PM me your Manager asset files (including UI prefabs, if used) for me to examine.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.