Forum rules - please read before posting.

Parallax 2D still not working in Version 1.50i

Hello Chris, 

Awesome updates!  Adventure Creator is seriously the greatest asset I could imagine.

However, I'm having an issue that you said was fixed in a previous update.  The Parallax 2D component doesn't seem to work in Version 1.50i (Mac).  I'm running this in UNITY version 5.3.3f1 personal edition.

In fact, for me, it hasn't worked for the last few updates.  When I released my demo, I had to release it without parallax scrolling due to this issue, which was a bummer.  It used to work beautifully in my game, but now... not at all.  No movement at all. 

The "Depth" function and "Offset" functions work like they're supposed to, I think.  But the "Constrain" function doesn't seem to do anything.  

In any case, no matter what values I enter, positive, negative, high, low (I've tried all combinations), it simply doesn't scroll parallax... aly...  

Any ideas?  Is this a possible bug?  Is it possible that I'm doing something wrong?  I doubt it, since I know how to use it.  I've used it before in past versions with no problems.  Let me know.  Thanks!


  • I will gladly be corrected wrong, but I do not believe there is a bug here - the parallax feature works just fine for me, and I'm using a Mac as well.  The background objects in the 2D Demo can be constrained just fine.

    Bear in mind that the values you enter in the Constrain fields are based on the MainCamera's position - so if your MainCamera's X co-ordinate is at e.g. 30, a typical X-constraint would be (28, 32) for example.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.