Forum rules - please read before posting.

UI Functionality Doesn't Work

edited October 2017 in Technical Q&A
Hi there,

I just bought Adventure Creator and am learning how to use it through the tutorial videos. However, one major problem I'm having is that the UI doesn't work at all. I'm doing the 2D Demo Tutorial and the menu option does not exist, I can't access inventory to make sure it works, and all text on both the cursor and dialogue options is non-existent. I've looked through the settings and nothing seems to enable this. Animating a character talking triggers the animation, but there are no words and none of the text or UI are appearing in-game.

Why is this and how can I fix this?

Using: Unity 2017.1.0p4 on Mac


  • Welcome to the community, @SuperSpark.

    To better understand the problem, we'll need to know a bit more detail about it.  What do you mean by "the menu option not existing"?  Are you referring to the Menu tab of the main AC editor window?  If you can share some images showing what's missing, it'll be easier to help.

    Your game's Menus are listed in the Menu Manager.  When you use the New Game Wizard to create a new set of Managers, you're given an option to begin with a default set of Menus or have a blank UI - which did you choose?

    The default set of Menus are listed in Section 11.3 of the Manual.  If you have no Menus listed in your Menu Manager, you can see what they should be by changing the "Asset file" at the top of the Manager to "Default_MenuManager".  You don't want to use this Manager directly, since it'll be overwritten when you update AC, but you can duplicate the asset and assign that instead.
  • edited October 2017
    Thanks for the welcome @ChrisIceBox. I hope to use AC for my next project.

    There's no Menu button at the bottom left in the game view. Additionally, moving my cursor up does not trigger the inventory drop-down. Pressing Escape Triggers the Pause Menu, but Save and Load don't work. Putting the cursor on an object does not put text identifying it either.

    I did choose Default AC when I made my test project, as said in the tutorial (which was autmatically set, so I left it alone). However, when I just checked my Menu Manager, the only Menus were Pause and Option. I went farther in the tutorial and did try to manually input the Subtitles Menu, but now I'll check that section of the manual to look at the settings. However, why didn't they appear when I setup the New Game Wizard?
  • edited October 2017
    This seems to be a consistent problem, @ChrisIceBox. I just finished the 2D Tutorial as much as I could and started the 3D one. Upon running the New Game Wizard, I noticed that this problem persists.
    • No Manager Package for the game is generated. Running the New Game Wizard Generates the Folder for the game and subfolders for individual Managers and UI. However, there is no Manager Package holding all the Managers together, so I cannot make sure they're all assigned.
    • Menu tab in the AC Game Editor is sparcely populated, it only has Menus for Pause and Options, and this time Save and Load.
    • I need to run the Basic Structure with Folders button in the scene view for any of the needed AC stuff to appear in the Hierarchy.

    Why is it not generating as it's supposed to?

  • edited October 2017
    Unsure yet - I'm afraid it's not an issue I can recreate.  Again, try assigning the Default_MenuManager - are all of the Menus appearing there?  There should be 13.

    Manager Package asset files can also be manually created by right-clicking inside the Project window - does that work?  It could be an issue with the Assets folder not being writeable - can't think why it wouldn't be, but that would at least be consistent with the behaviour you're experiencing.

    Also, check the Console for errors - are any relevant messages appearing?

    Regarding the Hierachy issue, you're saying that clicking e.g. "Create" next to the OnStart Cutscene field does nothing unless you're using pre-made folders?  Again, are there any Console messages appearing?

    To confirm, you're using v1.59e?  It may be that this is a Unity issue, in which case I would recommend upgrading to the latest official release, 2017.1.1.
  • edited October 2017
    So I checked the Default Menu Manager and it does list 13 Menus and I think might be the problem. It's not 13 Individual Menus (eg. Menu, Subtitle, Inventory, etc.) It just has 13 slots filled with the same "(Menu)" item which is based on itself.

    What I mean by the hierarchy issue is that if I complete the New Game Wizard, nothing is spawned in my Hierarchy. The only way that any of the needed components for the Adventure Creator appear is if I go into the AC Game Editor > Scene Tab > Basic Structure > With Folders. Then it will make the file structure we're familiar with. Otherwise the New Game Wizard won't set them up.

    I tried making a New Manager Package, but had to assign each package individual since Assign Packages did not automate it (if that's what that button was supposed to do). However, upon doing this for the scene I made based on the 2D Tutorial, the cursor stopped identifying my mouse and I'm no longer able to click on things. Weirdest of all is that I've received no errors during any of this.

    I'll try to upgrade but I don't feel like this particular issue shouldn't be present in a still recent edition of the engine.
  • edited October 2017
    Please let me know the version AC number.  It can be found at the bottom of each Manager window.

    The "Assign Managers" button only has an effect once the fields above have been filled - it will take the Managers listed and load them into the Game Window.

    What do you mean exactly about "(Menu)" appearing in the Default_MenuManager?  The Menu you're referring to is named "InGame".  Please post screenshots to illustrate.  How about the Demo_MenuManager asset.

    Try re-importing the Default subfolder from the Asset Store.  I apologise for the inconvenience.  This issue shouldn't be present, of course, but as it hasn't been reported before I can't rule out that this is related to the version of Unity being used.  To test out the write-issue theory, please try a fresh Unity project as well.
  • No worries Chris. I appreciate the fast support during all this.

    I'm using Adventure Creator ver 1.59c.

    Weirdly enough, while the Default Menu Manager has 13 slots with "(Menu)" in them, the Menu Managers for both the 2D & 3D Test Projects I started have only 4 slots.

    I tried re-importing with no dice. However, I did try it with a fresh Unity Project and that seemed to have solved it. I don't know what was wrong with the old project, but when I started a new entire project and ran the wizard it seemed to run work fine. Upon completing the wizard, the folder game objects appeared in the hierarchy, the new Manager Package appeared, and the AC Game Editor shows all the Menus being generated. Weird.

    Not sure why the old project is such a problem, though is there anything I can check or send you to look at in case it's something you want to look into?
  • Check the permissions and read/write access, as well as the "Asset Serialization" setting in the Unity Preferences.  As it's now working in a fresh project, it does sound something unique to your setup, so it's hopefully a one-off.
  • edited October 2017
    Hey @ChrisIceBox

    I've been doing some testing and I noticed something. Adventure Creator does not initialize properly unless it's the VERY first thing you do in a fresh new project. If I do anything, (eg. Load tutorial files, or other assets) Adventure Creator's New Game Wizard will consistently mess up. However, if I run the new game wizard immediately after starting up the new project, it will work fine.

    I'm not sure if that helps, but I was able to consistently recreate the problem in the above circumstances, as even running the new game wizard again on the project I previously mentioned it working on did not work properly. I don't know if it's just me, but this may be an important thing to look into as it might impede people who may be implementing AC mid-project or just not activating it first thing.
  • edited October 2017
    Thanks for the update, but could you elaborate on exactly what you mean by "activating" it?  Are you referring to merely importing it (which should be done before importing tutorial files) or using the NGW?

    If you could break down how to recreate the issue into bullet points, that will help a lot.
  • edited October 2017
    By "activating", I mean using the New Game Wizard. If I start doing anything decent to my scene before using the NGW, with Adventure Creator pre-installed in the project, it will not function correctly.

    To try and recreate the problem, I:
    • Started a new project
    • Told it to Import Adventure Creator on Project Setup
    • Opened the new Project
    • Did anything (eg. Import Evil Lair Tutorial Files, Open the 2D Demo, Work on another Scene, Make new Assets, etc)
    • Ran and completed the NGW

    Upon completing the NGW in this instance, I've consistently found that it doesn't setup the project properly for AC Creator; no folder objects will be added to the hierarchy, it will make Manager and UI folders with stuff in them, there will be no Manager Package asset what-so-ever, and the AC Game Editor's Menu Tab will have less Menus than its supposed to. There may be other issues, but I'm new to this, so that's all I could find.

    If I make a new project and run the New Game Wizard IMMEDIATELY after opening the new project, it will work properly and set itself up. However, so far that's the only way I've been able to get it to work so far on Unity. If I run the NGW again at any point after this successful run, it will have the same problems as before.

  • edited October 2017
    Thanks for the detail.

    You say you tell it to import on Project Setup - are you referring to the "Add Asset Package" feature that appears on the Unity Splash Screen when creating a new project?  If so, have you experienced this issue when importing AC from the Asset Store in an already-made project?
  • Yeah, I mean Add Asset Package, for my more recent posts.

    However, the original project I made, which prompted this thread, imported AC from the Asset Store and we've had this same problem now.
  • edited October 2017
    OK.  I've got this recreated in Unity 2017.  For pre-2017, all seems fine.

    Unclear of the cause at this point, but the Menu Manager created by the NGW is incomplete.  However, the Default_MenuManager is fine in my project.

    Please - what do you mean exactly about "(Menu)" appearing in the Default_MenuManager?  Screenshots to illustrate, so that I can precisely compare, will be very helpful.
  • Ah, so you were able to recreate it. I'm not crazy! Hope it's not too hard to fix.

    Here's a picture from the old menu managers. Forgot to post them earlier. Not sure if they should all be saying "(Menu)" or something else.

  • Thanks.  You're viewing the Manager asset through Unity's regular Inspector, which is why they're (correctly) appearing like that.  When viewed through the AC Game Editor, which is where Managers are designed to be viewed, they should look OK.

    The issue is *something* to do with a change Unity have made to AssetDatabase.CopyAsset, which the NGW requires in order to copy the default UI prefabs.  Whether this a bug on Unity's part, or AC is using it incorrectly, is not clear to me - however I believe I have a workaround, which I'll PM to you now.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.