Forum rules - please read before posting.

AC menu missing in unity 2018.2

edited May 2018 in Technical Q&A
So yeh the AC menu is totally gone from the top of unity for me (latest AC, but was happening before too), the only ac related warning I see is:

Assets/AdventureCreator/Scripts/Menu/Menu classes/Menu.cs(602,6): warning CS0618: `UnityEngine.Object.DestroyObject(UnityEngine.Object)' is obsolete: `use Object.Destroy instead.'

Im presuming thats not related to it, I wonder how this could happen ? Only affects my project, a fresh one it works as expected.

Got red errors in unity too not ac related but may affect things (not sure what this means)

Unloading broken assembly Library/ScriptAssemblies/Assembly-CSharp-Editor.dll, this assembly can cause crashes in the runtime
0x00000001415173A8 (Unity) StackWalker::GetCurrentCallstack
0x000000014151D8E6 (Unity) StackWalker::ShowCallstack
0x00000001413EDA5B (Unity) GetStacktrace
0x00000001408A19A0 (Unity) DebugStringToFile
0x0000000140BC5E5B (Unity) MonoManager::SetupLoadedEditorAssemblies
0x0000000140BBAB8C (Unity) MonoManager::EndReloadAssembly
0x0000000140BC4D8D (Unity) MonoManager::ReloadAssembly
0x0000000140E59943 (Unity) ReloadAllUsedAssemblies
0x0000000140E53FE1 (Unity) HandleCompileStatus
0x0000000140E5016A (Unity) CompileScriptsWait
0x0000000140E4F8B1 (Unity) CompileDirtyScriptsForEditorSyncInternal
0x0000000140E4F71D (Unity) CompileDirtyScriptsForEditorSync
0x0000000140E5A48E (Unity) ScriptCompilationPipelinePostProcessAssets
0x0000000141F87A4F (Unity) Postprocess
0x0000000141FA8B84 (Unity) AssetInterface::ApplyDefaultPostprocess
0x0000000141FB91AC (Unity) AssetInterface::ProcessAssetsImplementation
0x0000000141FC224A (Unity) AssetInterface::StopAssetEditing
0x0000000141FBDF81 (Unity) AssetInterface::Refresh
0x0000000141F74870 (Unity) AssetDatabase::Refresh
0x000000014141AB6E (Unity) Application::AutoRefresh
0x00000001415A489F (Unity) ContainerWindow::ContainerWndProc
0x00007FFB397FB85D (USER32) CallWindowProcW
0x00007FFB397FB54C (USER32) CallWindowProcW
0x00007FFB398119C3 (USER32) GetTopWindow
0x00007FFB39EF3F94 (ntdll) KiUserCallbackDispatcher
0x00007FFB371F10A4 (win32u) NtUserPeekMessage
0x00007FFB398102ED (USER32) PeekMessageW
0x00007FFB39810156 (USER32) PeekMessageA
0x00000001415C7FAE (Unity) MainMessageLoop
0x00000001415CA468 (Unity) WinMain
0x00000001423F953A (Unity) __scrt_common_main_seh
0x00007FFB39341FE4 (KERNEL32) BaseThreadInitThunk
0x00007FFB39EBF061 (ntdll) RtlUserThreadStart

+ a ton of substance material errors.

and weird stuff like this

Assertion failed on expression: '(srcInfo.GetChannelMask() & copyChannels) == copyChannels'

Think this all started when I moved to 2018 betas.


  • edited May 2018
    All plugin's menus won't appear until you get rid of all compilation errors. The broken assembly message may mean there's a problem with the project in the first place. You may want to try making a new project then move the stuff in your assets folder and settings folder to the new project. Also, native Substance support was dropped in 2018.1, Allegorithmic will be posting a plugin in the Asset Store instead. 

    Quote from Substance's integrations site: The built-in support for Substance materials will be deprecated in Unity 2018.1. To maintain compatibility, we are
    working on a new external plugin, with plans to release it on the Asset Store for 2018.1.
  • That's why it's best to avoid using the latest Unity release, unless you absolutely need something in it, as you're not leaving plugin developers the time to adapt to any changes that may affect their solution...
  • For projects started in 2017, you have to first download some sort of update for substances before updating the project to 2018. Allegorithmic uploaded a video for it on which can be found on youtube i believe.
  • edited May 2018
    Unfortunately I upgraded unity before I upgraded my substances. So not sure if that will work. I shouldnt have moved to 2018 I cant recall why I had to do so (or why I thought I did!) but it was a mistake and I cant go back :) Moving my project to a new one is probably not an option, it would cause a ton of hell I think (or would it *just* work?. This project is now 250gigs and 6 years old, it's been through a lot haha..... And even then im not convinced the errors would go if all the same content is back in the new one.

    Thanks for all the advice though guys. I tried deleting Library/ScriptAssemblies/ and reloading unity. Didnt help, im assuming substances are causing compile issues, so im hoping they release a way to fix after the event, I think I read that on forum. Otherwise I need to wipe all substances I guess, then that might fix it. 

    Really annoying though as I have ideas I cannot implement with AC until they're fixed.. I guess in the meantime im going to code them myself.

    Weird thing is I used to consider compiler errors were red warnings that *did not* go away when you clear the console, but these ones do. So I assumed there were serious warnings but not compile errors, for example I can still run my game. Anyway I blame it all on substances lol, real shame my game looked great before they removed the support and didnt warn me about the upgrade process - their upgrade note went up after I had done it.

  • The AC-related warning is minor and can be ignored (though will be addressed in the next update).

    It's generally best to only upgrade Unity version when necessary - certainly relying on beta releases should be limited to tests and non-critical projects.  The other errors you've posted are indeed not AC-related, and should be posted on the Unity forums instead - this may be a known issue with the current beta.
  • Thanks Chris, I need to be less trigger happy when I see a new beta... It's like a hunger for more speed.. one which is never satiated. lol... (though on an unrelated note I have noted a lot of my speed issues are from my cpus being throttled due to temperature!..) I think im going to wipe all my substances and see what happens :-o
  • edited May 2018
    Deleted all substances and many other things to get a rid of errors, i can make a build, ac runs, but the AC menu STILL does not show up, pretty much wasted 2 weeks of dev time on this. Now having to consider completely new ways to do things ;-/

    Other menus still turn up like RAIN, UMA and the new "substance" one.
  • @radiantboy Have you tried re-installing the latest AC?
  • Odd, I upgraded my Unity 2017 project to 2018.2 with no problem at all and the Adventure Creature menu appears fine :/
  • Yeh ive tried reimporting it, not sure if reinstalling would help, and I have my own optimisations in AC so each reinstall I have to reimplment all of them so not too keen to try again yet.

    This is not the first time unity has held me up for absolutely months as I painstakingly tear apart my project, lose hope and almost lose half a decades worth of work. I swear im getting quite sick of unitys performance and stability - not to mention the error messages dont lead you to anywhere.  It has me in awful situations at least once a month, not to mention how damn slow it is.

    Just tried latest unity beta deleted rain, uma and a ton of others but still the same. I wish quite often id picked unreal, unity is terrible in so many ways, only reason I stick with it is because ive just wasted 6 yrs full time learning how to use it. So yeah stuck, will neeed to think of another part of the game to implement instead, wish is a shame because the thing I was working on was meant to be played on huge projectors with cinema sized screens(!) on saturday to a huge crowd.. it was going to be some awesome exposure..

    Anyway the unity fight continues, awful tool.
  • If you have optimisation suggestions for AC, by all means suggest them here so that I can consider making them officially.
  • Sounds like you're having a bad time with it. Honestly though, I'd stay away from betas while you're so deep in development.
  • edited May 2018
    I think you should work on making AC compatible with the 2018.1 version wich is stable and not beta. I am trying a lot of stuff to make it work but it doesnt work. I even deleted the full directory from the prject an nothing happened.
    LE: I had some compilation error with Cinemachine. I deleted Cinemachine and AC got back. So conclusion is that if u have compiler warnings it wont show. Now it shows.
  • @VP_3
    are you saying you also have problems with AC not working correctly? does the menu show up?

    I see many optimisations that could be made, im thinking you have actually addressed many of them though because i was looking at old code, the hoptspot thing I think you fixed with layers or something, ie hotspots being detected miles away? I havent yet put that into play I dont think. My main optimisation which is not really a problem of yours is to stop npcs doing anything at all when off screen. I noticed a huge amount of cpu in npc or char fixed update i think about angles and stuff and my game dragged hellishly. So for better or for worse I made npcs bail out of that routine until a counter reaches a predefined amount. Ie, off screne 
  • If you're looking to disable/override NPC behaviour when off-screen, it might be better to have a script that changes their Motion control field to Manual when in that situation, and back to Automatic when on-screen again:

    • myNPC.motionControl = MotionControl.Manual;
    That may save you having to edit AC scripts upon each update.
  • upgraded unity today and deleted a ton of shaders and somehow all my menus came back, so i can now use AC again!..
  • in 2018.2 now works with no problems
  • Great! that one really did my head in, but yeah I almost forgot about it now thank god :)
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.