Forum rules - please read before posting.

WebGL Point and Move not working for the 3D Demo (Unity 2018.1.9f2)

edited March 14 in Technical Q&A

Hi, I bought your asset about a day ago and I have faced some issues regarding WebGL.
Adventure Creator (1.66.8) comes with a 3D demo. After booting up the demo, I converted the project to WebGL and exported the 3D demo. But the WebGL export produced the following problems when played on browser.
1.) Point to Move is NOT working. I can click on objects to interact and talk. But if I click on the floor to move tinpot, he does nothing.
2.) Tin Pot's mouth is not moving while talking. Brain's works fine but not Tin Pot.
You can check it since I tested these with the default package files.

PS: 2D Demo is working fine though.

Comments

  • Welcome to the community, @VasantJ.

    Point to Move is NOT working. I can click on objects to interact and talk. But if I click on the floor to move tinpot, he does nothing.

    Odd. What's the behaviour in the Editor? It may be Unity-specific as the online 3D Demo works fine. I shall attempt a recreation. There shouldn't be an issue with point-and-click movement in WebGL.

    Tin Pot's mouth is not moving while talking. Brain's works fine but not Tin Pot.

    You can check it since I tested these with the default package files.

    This is expected, since Tin Pot's mouth is procedurally-animated based on the volume of his speech audio. Unfortunately, the libraries to allow for this are not available in WebGL. When building the 3D Demo to WebGL above, I had to pre-bake his speech animations. This generally wouldn't be encountered in a real production, however, since mouth animations would normally be either lip-synced or hand-animated anyway.

  • Update: I can't recreate any such movement issue. Is the "Pathfinding method" in your Scene Manager still set to "Mesh Collider"?

  • Hi, the issue is not in the editor but the exported WebGL game files. Export the 3d demo as WebGL and click on the index.html file to play. You will notice that the click to move on the floor is not working.
    And yes, the pathfinding method is set to Mesh Collider.

    PS: Thanks for the Tinpot issue resolve.

  • edited March 15

    Export the 3d demo as WebGL and click on the index.html file to play.

    Exactly as I did, but it worked as intended. Is the "Click Marker" animated circle appearing, at least?

    Apologies for the trouble. This may be an issue with your project - you're welcome to zip up the whole folder and PM me a download link. As this isn't something I can recreate, that may be the only way to see what's wrong.

  • No, the "Click Marker" is not appearing. Could it have something to do with the Unity version then (2018.1.9f2)?
    It will take me some time to upload it, but I will send a dropbox link as early as possible for the project which is somewhere around 700mb.

  • No, the "Click Marker" is not appearing. Could it have something to do with the Unity version then (2018.1.9f2)?

    I don't think so. I've tested it in the same version.

    It will take me some time to upload it, but I will send a dropbox link as early as possible for the project which is somewhere around 700mb.

    You should be able to omit the Library folder, which should bring the filesize down considerably.

  • edited March 16

    Here it is. Link:

    Make sure to open it in the same version of Unity/

    On another note, is there any extra steps I need to take while exporting it to WebGL.

  • Hi, quick update. I used the Unity version 5.6.6 as per your asset recommendation and it works fine. So I am guessing it is definitely an version issue.

  • edited March 16

    I will take a look, but I've removed the link. You must not post public links to AC's source code - it is a commercial asset, which is why I asked for a PM.

    Please see the forum rules for more.

  • I have recreated your issue, now - I will look further into what's wrong.

  • okay sorry, first time on this site. Let me know if you find anything.

  • edited March 16

    Very strange - debugging so far has revealed no cause.

    This may even be a one-off project issue, given that my own 2018.1.9 test worked OK. If you don't mind, would you mind creating/testing a new project?

    This may be a bug with WebGL itself.

  • I already did. The one I sent you was the third project I created.

  • Anyways, Like I said in a previous post, it works with 5.6.6. So I am working with that version. So no hurry.

  • This appears to be an issue related to raycasting Mesh Colliders in Unity 2018.1.

    Upgrading to Unity 2018.2.17f1 resolved the issue for me.

  • ok thanks. will look into it.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.