Forum rules - please read before posting.

Hotspots yellow box not showing

Suddenly I realized that hotspots are not showing anymore. They are there functioning correctly but you can't see the yellow box. I can't really trace that to a recent update of AC that I did. Anyone has this thing happened to them ? Thank you


  • You probably just have Hotspots Visiblity set to off in the scene tab of the AC game editor.

  • No that's not it. I pressed visibility on for hotspots and nothing happens. Any other place I should look for ? Thanks

  • They'll disappear if you've collapsed the Hotspot Component in the Inspector for some reason. That might possibly be it

  • Yes, collapsing the Hotspot component would do it (since Unity won't call OnDrawGizmos in this case), as would unchecking Draw yellow cube? in its Inspector.

  • edited July 2019

    No I have 3 hotspots in the scene and they are all correct non collapsed! Anything else? If what you say was the case wouldn't making a new Hotspot be correct if I see all the components visible and non collapsed ? @HarryOminous @ChrisIceBox

  • edited July 2019

    The presence and shape of the box is still based on the collider attached to them - let's see some screenshots of a typical Hotspot's full Inspector and how it appears in the Scene window.

    AC and Unity version numbers too, please.

  • edited July 2019

    Unity Ver 2019.1.6f1 and AC Ver 1.68.2

  • one other possibility is that you might have inadvertently pressed "Off" in the AC Game Editor Scene Tab, for Hotspot Visibility. i believe that turns off all the yellow boxes no matter what their individual settings may be

    you wouldn't necessarily know you'd done it because there's no feedback on the Game Editor Tab to tell you what it's currently set to

  • @HarryOminous I thought of that and pressed everything to On again just in case but nothing happened. I must say that I have upgraded AC from the previous version to the 1.68.2 version. I can't really remember if the problem started after the upgrade but I am just giving this info also.

  • I suspect this is Unity related, rather than AC. Yellow box or not, the object's label should still be appearing, as this is a standard Unity feature set via the top-left of the Inspector (see the yellow oval icon just beneath the Inspector tab.

    Try going through the "Gizmos" toolbar to the top-right of the Scene window. You may have disabled Gizmos for Hotspots from there.

  • Hotspots are working even though I don't see the yellow box. I have tried Gizmos they are correctly set to visible.

  • OK so it is Unity related. Even though the Hotspots in Gizmos was set to visible. When I clicked on the Gizmos button ( which sets all Gizmos to visible ) the Hotspots appeared. So that solved it.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.