Forum rules - please read before posting.
Tech questions during the weekend? Drop in on the community Discord channel!

[Bug] Inventory item drag stops working at high timescales

edited July 2019 in Engine development

We are currently using a timescale speed up to streamline testing and reduce burden on our playtester. One of the bugs that appeared is that at a large timescale inventory item dragging stops working, it starts erratically triggering combine-with-self attempts.

I'm trying to investigate the precise problem point, but I haven't figured anything out beyond that.

The inventory menu setup is:
Menu Source: Unity Ui Prefab
Inventory box type: Default

Edit #1: Seems like CanClick is the culprit.

Comments

  • edited July 2019

    Edit #2: In PlayerInput.cs -> GetDeltaTime() returning Time.unscaledDeltaTime seems to solve the problem and work reasonably well with Pause mode as well, without custom constants. I haven't tested all the cases, but from what I understand the original GetDeltaTime() strives to do exactly what Time.unscaledDeltaTime does. Possibly written waaay before unscaledDeltaTime was introduced. (Since I think unscaledDeltaTime it's relatively recent)

  • I suspect your hunch is correct - thanks for the feedback, I'll investigate.

    For completeness, what Timescale are you testing with, and what are your AC/Unity version numbers?

  • I'm currently at 1.67.5 and my timescale is 10. (Strictly meant for testers to blitz to relevant game points)

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!