Forum rules - please read before posting.
Tech questions during the weekend? Drop in on the community Discord channel!

Character walking weird (skipping/flickering)

Hi

I'm suddenly experiencing a problem with my character. ii assigned him the default navmesh (as i've done a lot of times) but now my character is suddenly flickering/skipping in weird motions. the pathfinding seems to be right, but the character is just not following how he's supposed to. can you help me fix this?

https://youtu.be/CAiqbivikF8

Comments

    • What does this mean? It can play some of the animations but not others?

    Cannot play animation clip WALK__R (layer 0) on Mono

    -> AC debug logger
    UnityEngine.Debug:LogWarning(Object, Object)
    AC.ACDebug:LogWarning(Object, Object) (at Assets/AdventureCreator/Scripts/Static/ACDebug.cs:25)
    AC.AnimEngine_SpritesUnity:PlayCharAnim(String, Int32) (at Assets/AdventureCreator/Scripts/Animation/AnimEngine_SpritesUnity.cs:916)
    AC.AnimEngine_SpritesUnity:PlayStandardAnim(String, Boolean) (at Assets/AdventureCreator/Scripts/Animation/AnimEngine_SpritesUnity.cs:869)
    AC.AnimEngine_SpritesUnity:PlayWalk() (at Assets/AdventureCreator/Scripts/Animation/AnimEngine_SpritesUnity.cs:737)
    AC.Char:AnimUpdate() (at Assets/AdventureCreator/Scripts/Character/Char.cs:956)
    AC.Char:_Update() (at Assets/AdventureCreator/Scripts/Character/Char.cs:580)
    AC.Player:_Update() (at Assets/AdventureCreator/Scripts/Character/Player.cs:196)
    AC.StateHandler:Update() (at Assets/AdventureCreator/Scripts/Game engine/StateHandler.cs:382)

  • Chris will know better obviously, but to me at first glance it looks like the characters anchor/pivot point might be off center.

  • Indeed - check that the "Sprite child" object's Transform Position is set to (0,0,0), and that the sprite pivot points are at the graphic's base. If not, then I'd expect the kind of behaviour you're getting since the sprite is still pivoting around the y-axis as he turns.

    Cannot play animation clip WALK__R (layer 0) on Mono

    It means that there is no animation by that name in your Animator Controller. Bear in mind that AC will automatically add the underscore prefix before the direction latter (i.e. "_R") so you don't need to end your standard animation names with one in the Player's Inspector.

    You can use the 2D Demo game's Player character, Brain2D, for reference.

  • ok, så i've played around with the pivot point. all of my sprites pivot point is placed bottom center in the sprite editor. none of my animations have the sprite position included in the animation. the only positions in it is the positions of the ik solvers relative to the sprite. i tried adding the position of the sprite to the animation and put it to zero. this resulted in no skipping, but the sprite would always be off the mono gameobject center. i tried putting the position to 0,0,0 for all my sprites. somehow they're all off center form the gameobject when i zero the position values. how can i synchronize the pivot of my sprites with my mono gameobject??

    And concerning the animator: all of my animations are in there. i've tried changing the default animation, and when doing that it'll play the current animation, there's just no transition from the standard animation and to the different walk animation. how can this be?

  • Never mind i think i solved it! Thanks a ton for helping!

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!