Forum rules - please read before posting.

Cannot switch scenen even though all scenes are build

edited August 2019 in Technical Q&A

Hi there

I'm slowly but steady learning Adventure Creator and i would firstly like to thank this forum for all the help. I'm experiencing a weird problem since this is a function that worked last time i ran my game, but suddenly it doesn't and now i can't fix this.

I have a box gameobject (flyttekasseklam) with a hotspot on it (Flyttekasse)

This hotspot has and actionlist (Flyttekasse: examine) that should run when i click on it: walk to marker (not in the actionlist), then switching scene (on the actionlist).

My actionlist "Flyttekasse: Examine"

The thing is, my character walks to marker but then nothing happens.
I have all my scenes added to the build settings and it used to work, but suddenly it doesn't. i've tried to switch scene using the name and using the number of the scene but nothing works. Can you guys point me to where i may have missed something?

My hotspot script:

My scene build settings:

Thanks in advance.

  • Philippa

Comments

  • Are you getting any errors or warnings?
    If you put anything else inside the action list (like playing a speech) does it run?

  • i don't get any errors or warnings. and no, it won't run any kind of things i put in the actionlist

  • Then it won't be an issue with switching scenes, seems like the actionlist doesn't run at all. Sorry can't tell why. You can try to delete the interaction and create a new one instead, maybe it will help.

  • I've tried deleting both the actionlist and the hotspot. I made them again from scratch but it still doesn't work... hmm...

  • Other hotspots works fine?

  • Just to confirm: does the scene switch correctly if you run the ActionList manually? This can be done by clicking "Run now" at the top of its Inspector when Unity is in Play Mode.

    Assuming it does, then it seems to be an issue with the Hotspot. If you move the Interaction to a Use interaction (just create a new Use interaction and assign the same "Flyttekasse: examine" ActionList in its Interaction field), are you able to run it that way?

    I'm assuming you're using left/right clicks to use/examine Hotspots. If not, can you share details? Please also let me your AC and Unity version numbers, and I'll see what we can do.

  • i changed the hotspot to the "Use interaction" and now it works. thanks Chris and Keks, for helping me with my beginner noob questions!

  • Glad to help, but it's not a noob question - it's a bug! Changing the interaction type was just a way of determining the source. If you can let me know the details above (version numbers and input method), I'll see if I can recreate it.

  • version 2019.2.0f1
    and i'm not sure what you mean about input method, can you elaborate?

  • sorry that was my unity version. it's version v1.68.4 of AC

  • edited August 2019

    Thanks.

    I just mean how are you triggering the Use/Examine interactions? By default this is done with the left/right mouse buttons, but it's also possible to map them to input buttons named InteractionA and InteractionB.

    When you moved Examine to Use, you set everything up as it was ("Player action" field etc)? I can't reproduce such an issue. If you'd like to create a .unitypackage file that contains the scene file, your Player prefab, and your 8 Manager asset files, you can PM it to me and I'll take a look - it might be an issue unique to your project.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!