Forum rules - please read before posting.

hotspot icon visible even though hotspot is not visible for active camera

Hey,
I have hotspots with limited visibility only for one camera, but when I turn on "highlight hotspot based on cursor proximity" every hotspot icon is visible from every camera even though hotspot themselves are not clickable ( they correctly works only for their camera )

Is it intended? Or am I doing something wrong?

Comments

  • Sounds like a bug, I will attempt a recreation.

    Can you share a screenshot of your Settings Manager's "Hotspot settings" panel?

  • Recreated, thanks. I will work on a fix.

  • hey, I updated to 1.7 but its still the same for me

  • Not for me - I recreated the issue in v1.69.5 and cannot in v1.70.0.

    Assuming your Settings Manager hasn't changed, let's see the full Inspector of a Hotspot - at runtime - that shouldn't be showing its icon but is. Also, the contents of the "AC Status" window that you can enable at the bottom of the Settings Manager.

  • edited January 13

    I researched it bit more and realized I actually changed Hotspot settings to player vicinity.

    When I change it to mouse over as it was when I reported it, it works correctly.

    So I guess its only broken in player vicinity settings and its fixed in mouse over?

  • edited January 14

    Why I changed it is I realized its kind of hard to see whats interactive with just mouse over ( and it quickly turns to pixel hunt )- It works perfectly when I enable cursor proximity, but seems like cursor proximity doesnt work well with hotspot ray lenght ( it seems like it doesnt take ray lenght into consideration ) so when I enable it in some bigger scene it gets quite cluttered https://imgur.com/a/Sd6VmWM

  • Do you have colliders on the Default layer where the walls are? They should block Hotspot icons provided you've got Hide Hotspots behind colliders? checked.

    If you've changed your Hotspot settings, let's see your new Settings Manager.

  • edited January 14

    Hey Chris, yes I tried to enable Hide Hotspots behind colliders but it didnt really helped as you can still see hotpot icon at the other end of the location if there is no colider.

    I could probably somehow switch between mouseover/player vicinity between the scenes? ( as in the first scene in the car everything is in your vicinity all the time so mouse over works much better )

    Anyway, here is the new settings for player vicinity - https://imgur.com/a/9fO69VN

  • I can recreate this partially if you switch camera while a Hotspot is within the vicinity of the Player. I shall lool further into this.

    I could probably somehow switch between mouseover/player vicinity between the scenes?

    You can change any Settings Manager property through scripting - right-click the field's label to get an API reference to it. In the case of the "Hotspot detection method" field, it's:

    AC.KickStarter.settingsManager.hotspotDetection = HotspotDetection.MouseOver;
    
  • Yes its actually a case in my scene - player character is sitting inside car so all hotspots are within its vicinity all the time.

    Thanks for info Chris, I will look into it, switching settings would be probably most ideal solution.

  • Either way, this should be fixed in v1.70.2.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!