Forum rules - please read before posting.

Set Vertical Movement factor to 0

Hi there,

I am setting my controller inputs to allow only horizontal movement to my character (I used X axis on my Xbox controller). So far everything is going well but I would to like to set the Vertical Movement factor to 0 to avoid my character to move vertically. But at the same time i would like to use my Y axis to navigate inside my menus.
And I can't figure out how to prevent the movements.

Here 2 screens , my inputs manager and my movement settings

https://ibb.co/MstTvdT

https://ibb.co/MSfpNtN

thanks for the help ;)

Comments

  • edited January 18

    I assume your Movement method is set to Direct?

    You can use the Player: Constrain Action to disable movement in the Up and Down directions.

    As you have Turn instantly when under player control?, the Player should avoid moving up/down when turning. But if you want them to still show up/down animations when turning (but not move vertically), you can lay down colliders in your scene to block him - i.e. one above them, one below.

  • edited January 20

    Thanks for the answer, I apply a vertical constrain to my player and it's work fine.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!