Forum rules - please read before posting.
Tech questions during the weekend? Drop in on the community Discord channel!

Crash after loading a saved game from build

Hi all,
I recently make a build for Windows to test all the 70 scenes of my game.
Sometimes Unity crash during the building process but after a couple of crash, it created a build.
When I run it, works properly but when I save and reload the just saved game, the game crash with a ntdll.dll error like here:

Nome evento problema: APPCRASH
  Nome applicazione: Build.exe
  Versione applicazione: 4.7.0.29693
  Timestamp applicazione: 5669f24a
  Nome modulo con errori: ntdll.dll
  Versione modulo con errori: 6.1.7601.23338
  Timestamp modulo con errori: 56a1c6e6
  Codice eccezione: c0000005
  Offset eccezione: 000222e2
  Versione SO: 6.1.7601.2.1.0.256.1
  ID impostazioni locali: 1040
  Informazioni aggiuntive 1: 299a
  Ulteriori informazioni 2: 299ad8a2400bdbf1596ff10fc0d9641b
  Ulteriori informazioni 3: a30e
  Ulteriori informazioni 4: a30e761dc4904e3285b54f2718bc77a9

I selected only some scenes (from 0 to 39) and seems to save and load correctly. 
So I isolated the scene n. 40, made a build of that scene only and save/load works properly!
I don't know what else I can try to solve this issue... If somebody have some experience in that, please let me know!

Thanks

PS: using Unity 4.7.0 and AC1.49a
PS2: in the Unity editor, loading and saving game works correctly and no errors are shown...

Comments

  • Make another test: with a backupped copy of the game, I update AC to the latest version 1.50i, keeping the original menu manager of AC. 
    The game start, I make a new save and I get the same error when load it...  :-S
  • edited March 2016
    Back to my original project, with AC1.49a, now I have a new issue... I don't have modify anything in that project and before my upgrade (made in the other folder) all works in the editor... now, I have 3 error msgs when hit play. And if I try to go in the Setting window, it hangs! An empty window appear... and I cannot click on the other window.
    So I reimported AC1.49a with default MenuManager and worked but when I reimport my SettingMenu, the problem reappear! But it worked before the other folder update, so I don't understand why that happen... ~X(

    FormatException: Invalid length.
    System.Convert.FromBase64String (System.String s) (at /Users/builduser/buildslave/mono-runtime-and-classlibs/build/mcs/class/corlib/System/Convert.cs:146)
    AC.Serializer.DeserializeObjectBinary[OptionsData] (System.String pString) (at G:/Tortoise/Assets/AdventureCreator/Scripts/Save system/Serializer.cs:134)
    AC.Options.LoadPrefsFromID (Int32 ID, Boolean showLog, Boolean doSave) (at G:/Tortoise/Assets/AdventureCreator/Scripts/Options/Options.cs:188)
    AC.Options.LoadPrefs () (at G:/Tortoise/Assets/AdventureCreator/Scripts/Options/Options.cs:134)
    AC.Options.Start () (at G:/Tortoise/Assets/AdventureCreator/Scripts/Options/Options.cs:35)

    NullReferenceException: Object reference not set to an instance of an object
    AC.SaveSystem.GatherSaveFiles () (at G:/Tortoise/Assets/AdventureCreator/Scripts/Save system/SaveSystem.cs:130)
    AC.SaveSystem.Start () (at G:/Tortoise/Assets/AdventureCreator/Scripts/Save system/SaveSystem.cs:48)

    NullReferenceException: Object reference not set to an instance of an object
    AC.Options.GetProfileName (Int32 index, Boolean includeActive) (at G:/Tortoise/Assets/AdventureCreator/Scripts/Options/Options.cs:369)
    AC.MenuLabel.GetLabel (Int32 slot, Int32 languageNumber) (at G:/Tortoise/Assets/AdventureCreator/Scripts/Menu/Menu classes/MenuLabel.cs:477)
    AC.MenuLabel.AutoSize () (at G:/Tortoise/Assets/AdventureCreator/Scripts/Menu/Menu classes/MenuLabel.cs:532)
    AC.MenuElement.RecalculateSize (MenuSource source) (at G:/Tortoise/Assets/AdventureCreator/Scripts/Menu/Menu classes/MenuElement.cs:746)
    AC.Menu.PositionElements () (at G:/Tortoise/Assets/AdventureCreator/Scripts/Menu/Menu classes/Menu.cs:1187)
    AC.Menu.Recalculate () (at G:/Tortoise/Assets/AdventureCreator/Scripts/Menu/Menu classes/Menu.cs:1082)
    AC.Menu.Copy (AC.Menu _menu) (at G:/Tortoise/Assets/AdventureCreator/Scripts/Menu/Menu classes/Menu.cs:270)
    AC.PlayerMenus.RebuildMenus (AC.MenuManager menuManager) (at G:/Tortoise/Assets/AdventureCreator/Scripts/Controls/PlayerMenus.cs:103)
    AC.PlayerMenus.Start () (at G:/Tortoise/Assets/AdventureCreator/Scripts/Controls/PlayerMenus.cs:72)
  • Please post separate issues in separate threads, as it makes it easier to diagnose them.

    If Unity is crashing when building, is there anything non-AC you're using in scene 40, like another scripting asset?  There's no detail here to have any clue as to what the problem might be.

    For the second issue: fixes have been made to the save system since v1.49a, so upgrade to
    v1.50i and re-test.  If the errors still occur, re-post them as the line
    numbers will be different so that I can see what they refer to.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!