Forum rules - please read before posting.

Error on scene


When I go ot a new scene an error pops up:

Setting the parent of a transform which resides in a prefab is disabled to prevent data corruption.
AC.Menu:SetParent() (at Assets/AdventureCreator/Scripts/Menu/Menu classes/Menu.cs:359)
AC.PlayerMenus:OnLevelWasLoaded() (at Assets/AdventureCreator/Scripts/Controls/PlayerMenus.cs:178)
Im sure its something to do with unity UI, but not 100% sure. Any ideas?




  • The error is to do with AC trying to move the UI Canvas gameobject into the "_UI" scene folder.  The Canvas should be a gameobject in the scene, but it sounds like it's trying to affect the sourced prefab instead.  Does this occur when the game begins, or only when you move to a new scene?  If it works in the first scene, are all UI Canvases correctly moved to the "_UI" scene folder?
  • edited March 2016
    The UI folder gets populated with my menus.

    Pressing play in editor - no errors.
    Scene transitions - errors.
    Pause and quit- errors.
    Loading a game - errors.

    I have two sets of menus - Pause (normal game) and a StartPause (main menu)

    Essentially, one a copy of the other basically but called different and does slightly different things

    It all seems to work as it should tho... but produces this error, there a work around ? lol
    as long as the error dont disaply im happy, as it is the wii will fall over. That machine breaks just looking at it. Got try/catch around it but dont stop error showing.

    Update: I should note that im using the option Unity UI Prefab in the menu.
  • If you can work out exactly which Menu is the problem, PM the Canvas prefab + your Menu Manager to me.  You could workaround it by removing the _UI scene folder, but I'd like to find the cause - this is the second time this has been reported today.
  • edited March 2016
    Just another quick one.

    When I click something and player speaks, it creates a subtitle menu, if i do it again, another on is created, this can go on forever, and have millions of sutitle menus in the scene (deactivated tho).

    I tried turning all off and one on at a time, didnt seem to matter, still had prolblem, no matter which one was turned on/off.

    Here are my managers if you want a look.

    Never packaged anything before, so maybe overkill as i also had dependencies ticked.


  • Speech UIs not being deleted should have been fixed in v1.50c.  Which version are you using?
  • stuck on 1.47 init ;)

    couldnt update since the speech update. well, didnt want to, since would have to rename all those speeches again :O
  • do you think its because i got 2 canvases. 1 main one, and 1 inside of that ?

    For now, im just going to uncomment the line that parents the ui, just wont be in the _UI folder is all.
  • Removing the _UI folder would also do it.

    But what's stopping you from updating?  I can't help with any reported bugs if you're not using the latest.  If you're referring to the name of player speech lines, there's an option to use the player's real name.
  • I will try updating again, tried once, failed miserably.  Might be worth persevering with it until all errors and what not work work with the newest build. 

    I don't think its a small job though XD

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.