Forum rules - please read before posting.

Version 1.46 - Save game profiles, 2.5D tutorial



  •  v1.46e is now out.  Another critical bug involving draggables with UFPS, but a few minor fixes and additions made it in there, too:
    • Added: When the Scene Manager creates a new MainCamera, it will make one that is VR-compatible (Unity 5 only)
    • Added: Action: Comment headers can now display more text
    • Added: Buttons beside “Cutscene on reach” fields in Path Inspector to quickly create and assign Cutscenes
    • Added: “Sound: Play one-shot” Action - use to play a SFX audio clip once without the need for a Sound object
    • Fixed: Draggable objects no longer working with UFPS characters
    • Fixed: Character talking bools no longer being set correctly for Sprites Unity Complex animation
    • Fixed: Interaction and Inventory cursors not showing if main cursor is not set to always display
    • Fixed: Hotspots not being interactive when auto-positioned over a mesh with no scale
    • Fixed: Not being able to overwrite a saved game if the save file limit has been reached
    • Fixed: Unity UI-based Inventory menus showing empty slots
    • Fixed: Click sounds not playing for Unity UI-based Menus
    • Fixed: Warning messages when working in Unity 5.1.1
  • edited June 2015
    After updating my interactions lost constant ID's and now they run with Pause game instead of Run in background !!! How to avoid this sort of things?

    Also Hotspots lost custom collision boxes , now I have default boxes.

    How to update without AC changing things like interactions, hotspots etc.

    Some interactions and hotpsots have retain in prefab checked, if this rings the bell.

  • edited June 2015
    Updated and tested with savegames, all solved!  =D>

    The Sound: Play one-shot is a stroke of genius! 
    One suggestion to who's gonna use it, put "MainCamera" in the Position (optional).
  • @SkyTree: Unless you over-wrote AC's original prefabs, then updating AC shouldn't cause any such problems.  If you didn't, does this affect all interactions / hotspots, or just select ones?
  • I might have over-wrote AC's prefabs.
  • @SkyTree
    Usually, when I import a new release of AC, I uncheck those:

    Under Resources:

    Under ProjectSettings:
    *.asset (I uncheck all)

    This way, all my project settings remains the same while all scripts and other AC updates are make.
  • I had tried References before to no avail. Will try this Under ProjectSettings: *.asset (I uncheck all)
    next time.
  • Double check the Managers in AC's inspector tabs. I often find I have to replace my own managers if I accidentally import the Demo ones when upgrading.

    If you look and see 'demo....' managers in those boxes then you know you need to swap them back to your own project ones.
  • Yeah, the managers are mine. I think unchecking the references keeps the old managers.
  • I appear to have found a bug.

    I'm using Unity 5 and making a 2.5D game.

    When testing on Android and a game is saved on a scene that uses Sprite Overlays, those overlays appear messed up when that save game is loaded - i.e. characters appear in front of them rather than behind.
  • edited June 2015
    Also, when creating a new scene since the 1.46e upgrade, it doesn't seem to import the MainCamera properly when clicking 'with folders' when setting up the structure? It seems to duplicate the Main Camera by creating a main camera folder and placing ANOTHER main camera folder and LOOK AT in that folder?

    The console is saying: 

    MissingComponentException: There is no 'Camera' attached to the "MainCamera" game object, but a script is trying to access it.

    This is for a 2.5D game and I never had this problem before upgrading to 1.46e.
  • Just upgraded to 1.46e and i have two questions:

    1) Can I upgrade to the latest Unity version anytime or should I always wait until there comes the GO from you (in general)? Just tried out Unity 5.1.1 and veeery strange things happened. So I went back to 5.0.2 again and everything works normally again.

    2) Did something happen with the main camera in 1.46e? I'm not sure if the camera was named "MainCameraCam" before. In Unity's game-window, the whole scene is shown now, before it was exactly the same like the gamecam showed. But at play-mode, everything is fine, I just wanted to ask if this is a new feature. 

    Everything else seems to run fine :)

  • edited June 2015
    Yes, there's definitely an issue with the maincamera in 1.46e. I can't create any new scenes at the moment :(
  • The MainCamera prefab has now been split into two objects: the MainCamera script is the parent, and the Camera component itself now lies on the child.  This is to provide compatibility with Unity's new VR features.

    Please post the full error displayed in the console, regarding the MissingComponentException.

    You'll need to give more detail about the sprite overlay problem.  What's the difference in the scene view before and after the save?  Please post in a new thread.

    1) It's always best to wait for an AC update once a major Unity update comes out.  Unity like to change things around sometimes, and this causes problems with AC.  Then again, fixes and support come quicker if you report the errors you find.

    2) See above.
  • @ChrisIceBox

    Here's the full error:

    MissingComponentException: There is no 'Camera' attached to the "MainCamera" game object, but a script is trying to access it.
    You probably need to add a Camera to the game object "MainCamera". Or your script needs to check if the component is attached before using it.
    UnityEngine.Camera.get_rect () (at C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineCameraBindings.gen.cs:212)
    AC.BackgroundCamera.UpdateRect () (at Assets/AdventureCreator/Scripts/Camera/BackgroundCamera.cs:47)
    AC.MainCamera.SetCameraRect () (at Assets/AdventureCreator/Scripts/Camera/MainCamera.cs:1038)
    AC.PlayerMenus.UpdateAllMenus () (at Assets/AdventureCreator/Scripts/Controls/PlayerMenus.cs:1198)
    AC.StateHandler.Update () (at Assets/AdventureCreator/Scripts/Game engine/StateHandler.cs:169)

    I've tried creating new scenes over and over and keep getting the same message.
  • edited June 2015
    Thanks, Chris! Maybe you could include the latest supported Unity version in the Changelog of every new AC release? That would be great! 

    @ Unity 5.1.1 Errors: I was a bit concerned about the errors when they happened and forgot to note details before I downgraded again :( The main thing was that player dialog was displayed as narrator dialog even the "player line" option was checked. At game start, an error appeared in the log (something was missing) and I asn't able to move the player around in the scene. That's all i remember so far.
  • @ChrisIceBox

    Regarding the sprite overlay issue, I discovered it whilst testing on an Android device, it doesn't seem to do it when testing on PC.

    However, saying that it hasn't done it since so I'm slightly confused. We'll leave it for now but if it should happen again during testing I'll be sure to let you know. 

    Thanks for all of your hard work, Chris. It's very much appreciated.  
  • Annoyingly I have no problems with 5.1.1 myself.  Unity will ask to upgrade the project, and after doing so it all seems fine - the player lines work fine, at least in the demo.  @dude, does the demo game play properly?

    Another update is out, to fix the critical issue reported by @TayannaStudios.   Apologies for all these mini-updates.

    Version 1.46f:
    -Changed: When creating a new scene, the MainCamera’s Camera component will now be a child object
    -Fixed: Rare issues when running a scene created with v1.46e

  • Maybe the problems were caused by updating unity to 5.1.1 before updating AC. This time, i updated AC to 1.46f and updated Unity afterwards. Here's the results:

    - Upgrade from AC 1.46e to 1.46f in Unity 5.0.2
    - Message "Error importing folder (The pathName assets/adventurecreator/scripts/inventory is already mapped to c035f1e1c1ef3f844a37ccd13e24b5c5. But the meta data wants it to be mapped to b108aa6ef85d84975b122dbc9846fd15)" shows up in log (only once)
    - Game runs without any problems
    - Update Unity from 5.0.2 to 5.1.1
    - Start Unity 5.1.1 (Project is upgraded/rebuild to unity 5.1.1f1 at the start)
    - This time, no errors in the log appear
    - Player-dialogs are ok when the scene is started directly 
    - Player dialogs are narrator-dialogs after changing from one scene to another
    - After changing from title screen to scene 1, the camera settings seems to be different than before (has maybe to to with player position?)
    - player char doesn't move after scene changed, but moves normally when scene is started directly
    - Placing the player to the player-start marker doesn't work when changing to scene 2

    - 2D Demo works normally, but there is no scene-change, though.

    I will downgrade Unity to 5.0.2 again, for me there are no interesting features in 5.1.1 anyway.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.